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Motion 2 brings with it significant new features for the Motion user.

From extra precision—float space—to just plain silly fun—MIDI

behaviors—Motion 2 significantly improves the workflow of a motion

graphics project.

In this Lesson, we’ll take a look at the major new features of Motion 2.

We’ll begin by examining float space and why it’s important. We’ll then

build on what was learned in Lesson 12, by taking a look at some new

keyframing functionality. The brand-spanking new Replicator will also

get a review, along with some of the more significant new filters and

behaviors.
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Working in Float Space
Float space is important for a number of reasons. First of all, it’s really essen-

tial when working with content destined for output to film. Secondly, it can

protect the hours invested in perfecting your motion graphics program from

disappearing down the proverbial gurgler when you output to 8 bit video.

Finally, it enables you to make some dramatic changes to 3D renders without

flattening out the contrast. Just what is float space, and how is it able to per-

form these miraculous feats? These are all good questions, so read on!

Demystifying Float Space

NOTE � Float space is only available when working with Motion 2 on an

OS X 10.4 or above.

Float space can seem quite confusing at first, but we’ve enlisted the help of the

Stay Puff marshmallow man to help clear things up.

First of all, let’s recap what we know about the way Motion represents color

values. For every pixel in an image, there are separate red, green, and blue val-

ues, referring to the amount of red, green, and blue that make up the color of

that pixel. Motion allows each of these “channels” of color data to have values

from 0 to 1. A value of 0 is “suck-the-soul-out-of-you black” – you can’t get

any darker than zero. A value of 1 is “visitation-from-God bright” – that is, 1 

is the brightest a pixel can get on your computer monitor. So, a value of 1 in a

pixel’s red channel would mean that pixel is as red as it can get; a value of 0

would mean that there is absolutely no red in that pixel.

NOTE � As mentioned in an earlier chapter, other applications refer to

color values between 0 and 255, referring to the 8 bits of data used to store

color values in those programs. For the purpose of the current discussion,

just know that a value of 255 in those applications is equivalent to

Motion’s value of 1.

So what happens when you try to brighten pixels that already have color data

close to a value of 1? The answer is that the values clip to 1. That is, if you try

to brighten a pixel beyond a value of 1, its value will be set to 1. This results 

in flat areas of an image that lack any contrast detail. You may have seen this in
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digital video that was overexposed during filming. Once data in an image has

been clipped, you can’t recover it. If you try to reduce the brightness of the

image, you just end up with flat gray patches where the clipping occurred,

instead of flat white patches.

Clipped image

Clipped image with brightness reduced
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Unclipped image with brightness reduced 

So how what is float space, how does it help out with this clipping, and what

does it all have to do with the marshmallow man? Imagine that the marshmal-

low man stepped into a large auditorium with a concrete roof and stood up.

Let’s assume our friend Puffy is taller than the auditorium roof. As he stands,

his head is squished by the concrete roof. If he crouches back down again, his

head remains squished and looks horribly flat and deformed (what the marsh-

mallow community refers to as a bad s’more day). This is what happens to

normal color data when it’s brightened too far.

Now imagine instead that the auditorium had a false drop ceiling (you know,

the ones in corporate offices with the foam tiles made of some carcinogenic

substance). As Puffy stands up in this kind of building his head goes through

the drop ceiling, but it isn’t squished. To an audience member in the audito-

rium it may look just like the situation with the concrete roof, but instead of

being squished, the top part of his marshmallow head is simply hidden from

view. When he stoops back down, the part of his head hidden above the drop

ceiling is revealed again, exactly as it was to start with (albeit with the unfortu-

nate additions of carcinogens from the foam tiles).

This latter scenario is analogous to what happens in a float color space. In float,

image data is permitted to have values bigger than one and less than zero. Even

4 Motion 2



though a pixel will only ever be displayed to screen with a value of one (we’ve

already said that 1 is the brightest that a pixel will display to your monitor), the

pixels are allowed to have values above one in order to preserve their appear-

ance should a color correction ever bring their value back below a value of one.

So, instead of Puffy having his head permanently squished, the head is allowed

to live above the drop ceiling (the ceiling being the value of 1 in our color scale)

so that its shape is retained if it returns below the roof level later.

Float Space and Film

Float space is especially important for film work. Film images have a very high

dynamic range of colors—much bigger than the range that can be displayed

on a computer. When film images are brought into a computer, the black and

white points of the film are clipped to “fit” the most important parts of the

image onto the computer’s display. In normal color spaces, that means that

some of the subtle shadow detail is clipped to 0 and some of the fine detail in

the super-bright parts of the image (such as a cloudy sky) is clipped to 1. In

float space, this extra detail is retained unclipped, and can be recovered when

the footage is converted back out to film.

Float Space and Video

Even though video is traditionally stored as in 8-bit or 10-bit non-float format

(the number 8 or 10 refers to the number of bits per channel, a standard

image including red, green, blue and possible alpha channels), video compos-

ites can still benefit from float space. As we’ve already mentioned, the com-

puter works in an RGB color space, and each pixel has a red, green and blue

value defining its color. Video as it’s stored and broadcast out in the video

world, however, is stored in a different color space. In video, pixel values are

broken into a luminance component and one or two chrominance compo-

nents. The luminance component stores the basic contrast information of an

image, while the chrominance components carry the color information. Two

common formats are YIQ for NTSC, and YUV for PAL.

If an 8-bit RGB image is converted to an 8-bit YIQ or YUV image, rounding

errors in the conversion can often result in what’s called banding. This is
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especially common in fine graduated backgrounds. So after hours of tweaking

your particle system, you may find the beautiful collage of yellow and purple

looks like a topographical map of the Himalayas instead of the inspiring 

psychedelia you had intended.

Original image

Image with banding after conversion to video space
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The solution? You may have guessed it—float space. Simply put, float space

provides sufficient data “headroom” to perform the conversion to video space

without causing banding in the image.

Importing Float Space Images

As mentioned above, you can benefit from the extra data precision of float

space even when working with regular images. However, if you want to work

with float images created in another application or acquired from film,

Motion 2 enables you to do that as well.

Motion supports the OpenEXR file format for importing and exporting float

images. OpenEXR is an open source file format developed by the good people

at Industrial Light &Magic, and it has quickly become adopted as the standard

file format for storing float data. So if you want to import images already in

float space, make sure the application from which you are receiving the images

has exported them as OpenEXR. If your application doesn’t natively support

OpenEXR, do a quick search of the web—chances are someone’s already writ-

ten a free (or cheap) plug-in to do just that.

If you’re importing files from a film scanner, you’ll probably need

to convert the files from log to linear before importing the frames as

OpenEXR into Motion 2.

Setting Up Float Space in Motion
Working with float in Motion is very simple. The following steps will prepare a

project for work in float space.

NOTE � As mentioned earlier, float space is only available when operat-

ing Motion 2 on OS X 10.4 or later.

1 Launch Motion 2.

2 Press Cmd-O to open a project, navigate to the media accompanying this

lesson, and open Lesson 15 > FloatStart.motn
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3 In the File Browser, navigate to Lesson 15 > media, select RobotScene 

and click the import button at the top of the File Browser to import it into

the Canvas.

NOTE � If RobotScene appears as a list of several images, press the Show

Image Sequences as Collapsed button at the base of the File Browser.

You’ve just imported an OpenEXR float image into Motion, but by

default, the project is only set up to operate in 8 bit.

4 Press Cmd-J to open the Project Properties, or choose Edit > Project

Properties. Choose 32 bit (Float) from the Bit Depth pop-up menu, and

then click OK.

The Bit Depth pop-up gives you two float options: 16 bit and 32 bit. 32 bit

is best for film-resolution work, while 16-bit float will probably suffice for

video work.
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Notice as you look at the image in the Canvas that the highlights are

blown out (i.e., they appear clipped). If this was a normal image, there

would be no way to recover the clipped areas. Because this image was ren-

dered out of a 3D software package in float, reducing the brightness of the

image will recover the clipped areas.
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5 Select RobotScene in the Layers tab, then choose Add Filter > Color

Correction > Brightness.

6 In the Dashboard (press F7 to bring it up if it’s hidden), drag the

Brightness slider down to around 0.4.

Notice how the image in the Canvas gracefully darkens, and the highlights

on the round robot are much smaller than they were before you lowered

the brightness.
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While float space offers many advantages over traditional 8-bit color

space, it has the disadvantage of requiring a lot more render time to com-

pute. Rather than bog down Motion’s real-time design engine, an option

has been added to preview in 8 bit. This will give you the real time per-

formance you’re used to in Motion, but still allow you to create your final

render utilizing the full precision of float space.

7 In the View menu at the top-right corner of the Canvas, deselect Preview

Float Bit Depth.

Notice that as soon as you uncheck this item, the highlights on the robots

flatten. Toggle the Preview Float Bit Depth option a few times to see 

the difference. If you playback the timeline, you’ll notice that adjusting the

Brightness slider is much more responsive with the option deselected.
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That’s essentially all there is to working in float. As long as the project proper-

ties Bit Depth is set to float, your final project will render using float – regard-

less of the preview setting.

If you want to render out a file that preserves all of that extra float data, you’ll

need to use the OpenEXR format.

Saving to OpenEXR

Choose File > Export.

2 In the bottom section of the export window, choose Image Sequence from

the Kind pop-up menu.
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3 Click the options button, then in the Options window, set the Compressor

to OpenEXR. Click OK to close the Options window.

4 Choose a location and save name for the render and click Export to begin

rendering.

The Replicator
If you’ve been working with the original release of Motion for a while, you’ll

know how addictive the particle generator is. Good news: Motion 2 brings

another time-absorbing creative tool to the arsenal, this time with a name fit

for a California governor.

The Replicator is similar in some senses to the particle generator, and should

actually feel quite familiar. Where Motion’s particle system is designed to build

complex and often random simulations out of small, simple particles, the

Replicator is more about creating patterns. Swirly, exaggerated, video wall-

sized, psychosis-inducing patterns, to be exact.
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Creating a Replicator
Rather than try to explain the Replicator, let’s just take a look at how it works.

Press Cmd-Option-W to close any projects you may have open.

Choose File > Open, and open Lesson 15 > RepStart.motn

1 In the File Browser, navigate to Lesson 15 > media, select ClapBoard 

and click the import button at the top of the File Browser to import it 

into the Canvas.

2 Press the play button to begin playback.

3 At the top of the Canvas, press the Replicate button once.

Where there was once a single clapboard, you now have 25.

14 Motion 2



4 Click and drag one of the corner points of the bounding box you see

inside the are filled by the clapboards, and drag outwards to resize the

group of images.

5 As with the particle generator, there are many options available to adjust

the look of the replicator. Some of these are available from the Dashboard.
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6 In the Dashboard (F7), experiment with some of the different shape set-

tings, such as spiral. Return to the rectangle type when you’re finished.

Again, in similar form to the particle generator, there are many more con-

trols for the Replicator available from the parameters tab.

7 Make sure the shape setting has been set back to rectangle. About two

thirds of the way down the Replicator parameters tab (F4), set the Scale to

75%, and Scale End to 20%.

8 You’ll see now that the center clapboard is 75 percent of its original scale,

and the outer clapboards are 20 percent of the size of the center clap-

board, creating a nice falloff in scale.

Feel free to experiment with the various knobs and sliders; there are

countless other ways to customize your clapboard replicator.
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Applying the Sequence Replicator Behavior

Once a Replicator has been established, the various parameters defining it

can be animated with keyframes or parameter behaviors. However, a very

important new behavior specific to the Replicator can make animating the

pattern a very simple proposition.

1 Make sure the Replicator object is still selected, and choose Add Behavior >

Replicator > Sequence Replicator.

The Sequence Replicator behavior is very similar to the Sequence text

behaviors covered in Lesson 13 (see page 425). Several parameters can be

animated to create the effect.

2 In the Behaviors inspector (F2), click on the Add pop-up menu, and

choose Scale.
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3 Set the Scale to 75%.

You should now see the center clapboard slowly shrink to 75 percent of its

original scale during the first portion of the timeline, followed by the sec-

ond row, then the third row. It’s not too impressive yet, so let’s speed

things up.

4 Set loops to a value of 5.

The scaling down now occurs 5 times.

5 Set the Sequencing pop-up to Through.

The sequence now scales down, then back again for each of the 5 loops.

6 Set the Spread to 2.

There is now much more overlap between the rows, and the animation

looks much smoother.
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To finish the effect, let’s add some parameters other than Scale to be

adjusted with the sequence.

7 Using the Parameter Add pop-up, add the parameters Rotation, Color, and

Opacity. Set Rotation to 20 degrees, Opacity to 15%, and choose a red hue

for Color.

Starting to get the idea? The possibilities are, as they say, endless. Sadly, the

amount of time you can reasonably bill to the client is not.
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A New Way to Keyframe
In the original release of Motion, the Record Animation button at the base of

the Canvas determined whether or not changes made to parameters would

automatically create keyframes or not. (For a review, see Lesson 12). From the

standpoint of simplicity, this works great: Turn the record animation button

on, and any slider you move or value you change sets a keyframe at the current

frame. The only major downside to this method is that if you forget to turn it

off, you end up with a mess of unintended keyframes to clean up.

Motion 2 brings with it the solution, the “Record keyframes on animated

parameters only” option. A mouthful to be sure, but also a lifesaver. What it

means is that when the option is enabled, automatic creation of keyframes will

only occur if the parameter being adjusted already has keyframe set. Motion

graphics artists coming from After Effects will be familiar with this; it’s the

default method for keyframing in that application.

This new method will make much more sense in a moment, as you actually

perform the steps.

20 Motion 2



Using the Animated Parameters Only Option

1 Press Cmd-Option-W to close any open projects.

2 Choose File > Open, and open Lesson 15 > KeyStart.motn

3 Double-click the Record Animation button at the base of the Canvas to

activate it and jump immediately to the Recording Options window.

4 In the Recording Options window, select the “Record keyframes on 

animated parameters only” checkbox, then click OK.

5 If you’re not already there, move to frame 1. Make sure Clapboard is

selected, and in the Properties inspector (F1), option-click the Animation

Menu button (the minus sign) to the right of the Position parameter.
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We’ve now set a keyframe for Position. It’s now considered an “animated”

parameter, since it has at least one keyframe (the one we set here at frame 1).

6 Move to frame 100.

7 In the Canvas, drag the Clapboard to the upper-right corner of the screen

and release the mouse. Then use the rotation control (the small hollow

circle just to the right of Clapboard’s center) to rotate the Clapboard

45 degrees to the right (clockwise).

8 Move back to frame 1, and then resume playback.

Notice that the clapboard’s position animates – it moves from the lower-

left to the upper-right – but its rotation does not. That’s because we never

set any keyframes for Rotation. It’s therefore not considered an animated

parameter and a keyframe was not set at frame 100.
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Let’s set one more point, just to drive the idea home.

9 Move to frame 50. Adjust the position of the Clapboard to the lower-

right of the screen, and adjust the rotation even further in the clockwise

direction.

10 Move back to frame 1 and resume playback.

The Clapboard now animates through the new position keyframe at 

frame 50, but since rotation is not an animated parameter, no keyframe 

is set and the rotation remains at its most recent setting throughout the

timeline.
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New Filters, Generators and Library Features
Along with the improved functionality of Motion 2, several new filters,

generators and other library items are available. A few of the more notable 

are described briefly here.

The Caustics Generator

The Caustics generator creates a nice ripple effect, similar to the highlights

found on the top of a disturbed water surface. Try using this with a distortion

filter like Displace for a nice effect.
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The Basic 3D Filter
Found in the Distortion section, the Basic 3D filter provides a nice way of

performing simple perspective adjustments to elements in order to simulate

3D space.

The Matte Magic Filter
Matte Magic provides a much more powerful method for expanding or con-

tracting the edges of a matte than the previous Matte Choker filter (referred to

in Lesson 9, on page 290).
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The Channel Swap Filter
The channel swap filter is an uninspiring but incredibly useful filter for switching

image data from one color channel to another. Very useful for transferring mattes

to and from the alpha channel of an image.

The Refraction Filter
This filter creates a glassy effect by default, or it can be used with a control

image (applied to the image well in its parameters) to distort an image in a

specific way.

The Scrub Filter
This filter was actually available for the original release of Motion, but was a

separate “thank you” download if you registered Motion at the Apple website.

It’s now bundled with the full version of Motion 2 and ready to go. Basically,

it allows you to shift the timing of a clip forwards and backwards, something

akin to scrubbing a vinyl record on a turntable, but with video. Now, use this

with the new MIDI parameter behavior (see the section below), and things

start to get interesting.

Core Image Units
Just when you thought you’d run out of generators and filters, Motion 2

offers access to the Core Image filters that ship with OS X 10.4 Tiger. They’re

available in the Library under the two categories called Image Units, one for
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Core Image generators, and the other for Core Image filters. Of course, just

like working with float, you’ll need to be running OS X 10.4 or later to take

advantage of these.

Core Image Filters and Generators are available in the Library under two sections,
both labeled, “Image Units”

Many of the Core Image filters are duplicates of filters already available in

Motion, but there are several that are distinct. Of particular note are the

Lenticular Filter generator, and the Stylize (check out the Spot Light filter)

and Composite Operations (useful for more complex and isolated composit-

ing tasks) filter categories.

The Lenticular Filter generator
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iPhoto and iTunes Support
In Motion 2, iPhoto and iTunes content is available directly from the Library.

What’s more, playlists and photo albums are recognized, so you can have the

work experience kid sort through your library for the photos and music

tracks you’ll need for the current project, and they’ll be effectively “soloed”

in Motion’s library, ready to go.

Motion Path Enhancements
Yet another reason to leave keyframing alone. The Motion Path behavior has

received a facelift and now offers several different methods for modifying the

way an object travels along its path.

If you hadn’t worked with the Motion Path behavior before, this new imple-

mentation may save you the headache of frame-by-frame keyframing.
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Working With MIDI Parameter Behaviors
Alright, all those former musicians who ended up in the film and video indus-

try after needing to find a real job, this is your chance. Pull out that old MIDI

keyboard or foot controller hiding in the closet and put it to use.

Motion 2 allows you to map MIDI events to parameters. What this means is

that you can perform real-time adjustments to filters and behaviors by moving

a MIDI slider, or pressing a key on a MIDI keyboard.

Setting Up MIDI Control
The process to access MIDI control in Motion is very simple.

1 Make sure your MIDI device is already powered up, connected to your

Macintosh, and recognized by OS X as a valid MIDI input.

2 Right-click on the parameter you want to control, and choose MIDI.

This automatically adds a MIDI parameter behavior and sets it to “learn-

ing” mode.

3 Move a MIDI slider, dial, expression pedal, or keyboard key. Motion will

identify what was pressed and map it to the chosen parameter.

4 Adjust the Scale parameter to suit.
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The Scale parameter determines how much influence the MIDI hardware

will have on the parameter. Set to the default value of 1, the assigned

slider, key, or knob will adjust the parameter from 0 to 100 percent of its

original value.

Go ahead and experiment.

Using Motion Menu Loop Point Markers
One more new feature in Motion 2 definitely worth mentioning is the Loop

Point marker feature for use with DVD Studio Pro 4.

Motion menus typically build or fade up from black at the start. When a

motion menu loops back to its start (usually 30 or 60 seconds after it com-

mences) it’s “bad DVD authoring etiquette” to force the viewer to wait for the

menu to build again before being able to make a selection. Instead, the DVD

should jump to the point directly after the menu has finished building. This is

known as the loop point, and in Motion 2 you can specify exactly where you

want that to be with a marker. DVD Studio Pro will then automatically set the

loop point to your marker.

1 Move to the frame at which you want the loop point to occur.

2 Press Shift-M to create a marker.

3 In the Timeline (F6), double-click the created marker to edit it.
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4 In the Edit Marker window, choose DVD Menu Loop from the type pop-

up menu and click OK.

Now, if the project is imported as an asset into DVD Studio Pro, the loop

point will be set to the designated frame.

Working with Other Applications

Final Cut Studio Integration
In addition to the integration previously seen between Final Cut Pro and

DVD Studio Pro, Motion now integrates with the new post-production audio

tool, Soundtrack Pro. Individual audio files can be non-destructively edited in

Soundtrack Pro, then automatically updated back in Motion.

Final Cut Pro integration has also seen the addition of marker and audio

keyframe export into Motion.

Integration Outside of Studio (Including After Effects)
Perhaps the really big news in integration is the interaction with other software

via QuickTime. What this means is that After Effects can access Motion content

without having to first render the Motion project. Simply by renaming the

extension of the Motion file to .mov, After Effects will be fooled into thinking

the project is a QuickTime movie and import it just like any other footage. Nice.

Motion projects can now automatically be imported as elements

into Shake 4.0 (no file extension change required).
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Lesson Review
� Motion 2 brings with it powerful new functionality, in addition to new fil-

ters and behaviors.

� Float space offers color precision required for film work, which can also

prevent degradation in imagery destined for video.

� The Replicator provides a unique system for generating pattern effects.

� Motion 2 adds the ability to keyframe only on animated parameters when

in Record Animation mode.

� New filters and generators have been added to increase the creative possi-

bilities of Motion.

� MIDI behaviors allow parameters to be adjust in real-time by MIDI hard-

ware devices.

� DVD Menu Loop markers allow DVD Studio Pro to automatically set a

motion menu loop point.

� Motion 2 integrates now integrates with Adobe After Effects, in addition

to the Apple Final Cut Studio applications.
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