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ERRATA 
 
Page 17, step 1 should read: 
Place your cursor anywhere in the header text, “Your vacation wonderland awaits”. 
 
Page 32, step 1, second sentence should read:  
". . . select the phrase On A Shelf including the space following Shelf." 
 
Page 35, step 1, line 2: example_file.html should be changed to 
example_page.html 
 
Page 46, step 1, line 2:  example_file.html should be changed to 
example_page.html 
 
Page 50, step 1, line 2:  example_file.html should be changed to 
example_page.html 
 
Page 71, step 4, paragraph after the Note, first sentence should say, “Note that the paragraph is now 
center aligned…” 
 
Page 133, third bullet should say, “Create a link…” 
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Working with Text
LESSON 4

The inserted text will be added at the top of the column on the right.

3	 In the Files panel, expand the lesson04 > assets folder.

4	 Drag the Spirit_text.doc file from the Files panel and drop in on the Web page in 
the current cursor position.
When you drop your dragged file, Dreamweaver recognizes the file as a Word document 
and opens the Insert Text dialog box. This dialog box presents a range of paste options 
from basic text to full formatting, along with an opportunity to insert a link to the 
external document.

Note: The above step is a Windows only operation. Macintosh users should open the 
document in Word and copy all the contents to the clipboard. Then, in Dreamweaver 
choose Edit > Paste Special and select the Text with structure plus basic formatting (bold, 
italic) option. Deselect “Clean up Word paragraph spacing” and click OK.
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Working with Text
LESSON 4

7	 Place your cursor in any of the list items of the bulleted list and choose  
Window > CSS Styles. In the CSS Styles panel, click Current to switch to Current  
mode. In the Rules panel, select ul li and click Edit Style. When the CSS Rule  
Definition for ul li in main.css dialog box opens, click List in the Category area. From 
the Type menu, choose disc and click OK.

8	 Chose File > Save All to store changes both to the HTML and CSS files.

Spell	checking	your	document
It’s important to make sure the content you post to the Web is error-free. Dreamweaver 
includes a robust spell checker capable of identifying commonly misspelled words and 
creating a custom dictionary.

1	 If necessary, re-open the spirit.htm file worked on in the previous exercise by 
double-clicking its entry in the Files panel. 

2	 Place your cursor in the <h1> heading, Driven by imagination, and press 
Ctrl+Home (Windows) or Cmd+Home (MacOS) to move the cursor to the top of the 
page.
Dreamweaver starts the spell check operation from the current cursor position and 
when it reaches the end of the document offers to start again from the top, if necessary. 
By positioning the cursor at the top of the document, this step is avoided. 
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5	 Click	Browse	(Windows)	or	New	Folder	(MacOS)	to	select	a	new	subfolder.	When	
the	Select	Folder	dialog	box	opens,	navigate	to	the	lesson05	>	images	>	navbar	folder	
and	click	Save	“navbar”	(Windows)	or	Choose	(MacOS).	Once	you’ve	returned	to	the	
Export	dialog	box,	click	Save	(Windows)	or	Export	(MacOS).

6	 After	the	operation	is	complete,	choose	File	>	Save	and	close	Fireworks.

The	export	operation	is	deceptively	quick.	From	a	single	graphic,	Fireworks	created	
an	HTML	file	with	all	the	sliced	images	in	a	single	HTML	table,	complete	with	spacer	
images	for	cross-browser	compatibility.	Additionally,	each	of	the	individual	graphics	is	
saved	in	the	subfolder,	for	both	standard	and	rollover	states.

7	 If	necessary,	start	Adobe	Dreamweaver	CS3.

c05im.indd   119 6/25/07   3:14:54 PM



6

In this lesson, you’ll learn how to apply different kinds of links to various 
page elements by doing the following:

• Apply a text link to a page within the same site.

• Link from an image.

• Create a link to a page on another website.

• Establish an email link.

• Link to a specific part of a page.

This lesson will take about 60 minutes to complete.  Be sure you have copied 
Lessons/Lesson06 from the Adobe Dreamweaver CS3 Classroom in a Book 
CD to your hard drive before beginning. As you work on this lesson, you’ll 
overwrite the start files. If you need to restore the start files, copy them again 
from the CD.

Previewing your completed file
To get a sense of the file you will work on in the first part of this lesson, let’s 
preview the completed page in the browser.

1 Start Adobe Dreamweaver CS3. 

2 If necessary, press F8 to open the Files panel and choose DW CIB from 
the site list. 

3 In the Files panel, expand the lesson06 folder.

Inserting Links
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Crafting Page Layouts
LESSON 7

6	 From	the	Common	category	of	the	Insert	bar,	click	Insert	Div	Tag	( ).	When	the	
Insert	Div	Tag	dialog	box	opens,	leave	the	Insert	list	at	the	default	option,	At	insertion	
point.	From	the	ID	list,	choose	wrapper	and	click	OK.

Dreamweaver	adds	the	new	<div>	to	the	page,	with	the	placeholder	content	that	reads:	
Content	for	id	“wrapper”	Goes	Here.

Note: If you don’t see a dashed outline around the newly-inserted <div> tag, choose CSS 
Layout Outlines from the Visual Aids menu button on the Document toolbar.

7	 Press	F4	to	close	all	panels	and	display	the	Document	window	fully.	Notice	that	the	
outlined	<div>	tag,	#wrapper,	is	centered	in	the	Document	window.	Press	F4	again	to	
redisplay	the	panels	and	choose	File	>	Save.

Now	that	the	outer	wrapper	is	in	place,	let’s	add	the	major	layout	divisions.

Setting up the primary divisions

The	current	design	can	be	divided	into	three	major	areas:	header,	content	section	and	
footer.	Each	of	these	areas	requires	a	separate	CSS	rule	and	<div>	tag.

1	 If	necessary,	re-open	the	layout_start.htm	file	worked	on	in	the	previous	exercise	by	
double-clicking	its	entry	in	the	Files	panel.

Let’s	define	the	first	of	our	CSS	rules,	#header,	to	start.
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5	 In	the	CSS	Rule	Definition	for	#content	dialog	box,	click	Box	in	the	Category	
column.	Clear	the	Same	for	All	checkbox	in	the	Padding	area	and,	in	the	Top	field,		
enter	0.	Uncheck	the	Same	for	all	checkbox	in	the	Margin	area	and	enter	0	in	the	Top	
field.	Click	OK	when	you’re	done.

The	final	CSS	rule	to	declare,	#footer,	is	similar	enough	to	the	#header	rule	that	you	can	
take	a	short-cut	to	creating	it.

6	 In	the	CSS	Styles	panel,	right-click	(Windows)	or	Ctrl+click	(MacOS)	on	the	
#header	style	and	choose	Duplicate	from	the	pop-up	menu.	When	the	Duplicate	CSS	
Rule	dialog	box	is	displayed,	enter	#footer	in	the	Selector	field	and	click	OK.

When	you	duplicate	an	existing	style	rule,	the	new	rule	is	inserted	without	the	CSS	Rule	
Definition	dialog	box	appearing.	If	you	need	to	make	any	adjustments,	you	can	use	the	
Properties	pane	of	the	CSS	Styles	panel.
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7	 Select	the	placeholder	text	Content	for	id	“leftColumn”	Goes	Here	and	press	Delete	
(Windows)	or	forward	delete	(MacOS).	Enter	Subheading.	In	the	Property	inspector,	
choose	Heading	2	from	the	Format	list.	Place	your	cursor	after	the	just	entered	text	and	
press	Enter	(Windows)	or	Return	(MacOS)	to	create	a	new	line	below	the	heading.

To	spare	you	the	chore	of	typing	in	a	paragraph	of	placeholder	text,	I’ve	included	a	file	
that	you	can	copy	and	paste	onto	the	page.

8	 Place	your	cursor	after	the	word	Subheading	and	press	Enter	(Windows)	or	Return	
(MacOS).	From	the	Files	panel,	expand	lesson07	and	double-click	placeholder_text.
htm	to	open	it.		Choose	Edit	>	Select	All	and	then	press	Ctrl+C	(Windows)	or	Cmd+C	
(MacOS);	when	you’re	done,	choose	File	>	Close.	When	you	return	to	layout_start.htm,	
press	Ctrl+V	(Windows)	or	Cmd+V	(MacOS)	to	paste	the	copied	text.

Let’s	put	the	exact	same	content	in	the	right	column	with	a	quick	and	easy	shortcut.

9	 With	your	cursor	in	the	left	column,	choose	Edit	>	Select	All.	Notice	that	only	the	
text	within	the	#leftColumn	<div>	tag	is	selected.	Press	Ctrl+C	(Windows)	or	Cmd+C	
(MacOS).	Select	the	placeholder	text	Content	for	id	“rightColumn”	Goes	Here	and	press	
Ctrl+V	(Windows)	or	Cmd+V	(MacOS)	to	paste	the	copied	content.
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In Dreamweaver, the Select All command initially selects the content within a container, 
such as text in a table cell or content in a <div> tag. � is allows you to quickly copy or 
move content from one location to another. Repeat the command once more to select 
the container and a third time to select everything on the page.

10 Choose File > Save.

Now your layout design is both structurally sound and easy to follow. Congratulations!

Exporting  CSS styles
� e layout page worked on in the previous exercises is now complete unto itself. 
However, before this page is put into production, it’s a good idea to move the CSS styles 
from the <head> of the document to an external CSS style sheet. Dreamweaver o� ers a 
command to handle that task quickly and easily.

1 If necessary, re-open the layout_start.htm � le worked on in the previous exercise by 
double-clicking its entry in the Files panel.

2 In the CSS Styles panel, select the � rst de� ned style, body, press Shi�  and select the 
last style, #rightColumn.

3 From the CSS Styles panel Options menu, choose  Move Rules.

  You can also right-click (Windows) or Ctrl+click (MacOS) to reach the same menu 
option.
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LESSON 9

4	 Select	the	spry_final.htm	file	and	press	F12	(Windows)	or	Option+F12	(MacOS)	to	
preview	it	in	your	primary	browser.

The	page	includes	a	variety	of	Ajax-powered	effects,	all	created	with	Dreamweaver	Spry	
technology.

Note: If Internet Explorer 7 is your primary browser, you’ll need to take some additional 
steps to view the Spry dynamic content locally. First, your site must be within the local 
server Web root; be sure your Lessons folder is stored in the Inetpub > wwwroot folder.  
Next, double-click the site name in the Files panel to open the Site Definition dialog. Click 
the Testing Server category; from the Access list, choose Local/Network. Click OK to close 
the Site Definition dialog. Now, when you preview your page with Internet Explorer, your 
local Web server (localhost) serves the page as designed.

When	the	page	initially	loads,	you’ll	notice	a	yellow	background	color	highlights	the	
primary	headline	for	a	brief	period	and	then	disappears;	this	is	the	result	of	a	Spry	effect	
called	Highlight.

5	 Click	the	column	header	Since	once	to	sort	the	data	by	the	year	in	an	ascending	
order;	click	it	again	to	sort	the	data	by	year	in	a	descending	order.	Click	the	column	
header	Company	to	present	the	data	in	alphabetical	order.

6	 Move	your	cursor	over	the	various	entries	in	the	table	of	data	in	the	left	column.	
Click	the	last	entry	in	the	table.

When	you	select	any	data	entry	from	the	data	table,	the	associated	image	appears	in	the	
right	column	and	related	details	are	displayed	in	the	accordion	panel	below	the	figure.
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9	 Choose	File	>	Save.

10	 When	the	Copy	Dependent	Files	dialog	box	appears,	review	the	files	you’ll	need	to	
upload	and	click	OK.

	Although	there	is	no	obvious	change	in	Design	view,	Dreamweaver	has	inserted	
a	number	of	key	code	lines.	In	addition	to	the	previously	noted	JavaScript	files,	a	
JavaScript	function	is	included	in	the	<head>	tag:

var ds1 = new Spry.Data.XMLDataSet(“clients.xml”, “clients/clien

t”,{sortOnLoad:”company”,sortOrderOnLoad:”ascending”});

ds1.setColumnType(“pic”, “image”);

ds1.setColumnType(“startdate”, “number”);

This	JavaScript	function	applies	all	the	parameters	chosen	in	the	Spry	XML	Data	Set	
dialog	box,	including	the	column	types.

In	the	next	exercise,	you’ll	put	the	Spry	data	connection	to	use	by	inserting	a	Spry	table	
object.

var ds1 = new Spry.Data.XMLDataSet(“clients.xml”, “clients/clien

t”,{sortOnLoad:”company”,sortOrderOnLoad:”ascending”});

ds1.setColumnType(“pic”, “image”);

ds1.setColumnType(“startdate”, “number”);
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Building Spry data sets
The data from a Spry XML data connection on the page is often presented in a simple 
two-row table. The top row of the table contains the column headers, which can 
optionally sort the data below. The second row of the table holds the data variables that, 
when the page is browsed, are replaced by the actual data values. The second table row 
tag includes an attribute which causes the row to repeat as many times as necessary 
to display all the data. Other attributes to style the odd and even rows differently or 
to change styles when the page visitor’s mouse hovers over a row or selects it are also 
optionally placed in the second <tr> tag.

Coding such a data-connected table by hand is entirely possible, but quite tedious and 
requires in-depth understanding of Spry attributes and values. Luckily, Dreamweaver 
includes an object—the Spry Table—which creates the entire table in one operation, 
without touching the code. The Spry Table displays a master list of the available data 
with just enough information to identify the data record. Another area on the page—the 
detail region—is necessary to show additional related data, including associated images 
and text.

Adding a Spry Table

In this exercise, you’ll insert a Spry Table onto the page, configured to show your XML 
data when previewed in a master region.

1 If necessary, re-open the spry_start.htm file worked on in the previous exercise by 
double-clicking its entry in the Files panel.

2 Select the placeholder text Data placeholder and press Delete (Windows) or 
forward delete (MacOS).

3 From the Spry category of the Insert bar, click Spry Table ( ), the fifth icon from 
the left.

The first major task in the Insert Spry Table dialog box is to choose which data 
columns to display. As all available columns are shown initially, this task is a process of 
elimination where you remove those columns you do not wish to show.
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4 Select the placeholder text Description placeholder and press Delete (Windows) or 
forward delete (MacOS). Choose Window > Bindings. In the Bindings panel, select desc 
and click Insert.

Dreamweaver inserts the code for the Spry dynamic text, {ds1::desc}, which represents 
both the data set, ds1, and the chosen data element, desc. Finally, let’s add the second 
data text element.

  If you only have one data set on a page, you can omit the data set reference. For 
example, {ds1::desc} could be written {desc}.

5 Select the placeholder text Work placeholder and press Delete (Windows) or 
forward delete (MacOS). From the Bindings panel, select work and click Insert.

To complete the connection between the master and detail regions, you’ll need to 
identify the  Spry  detail  region area of the page.
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7	 Select	the	placeholder	phrase	Content	1	and	press	Delete	(Windows)	or	forward	
delete	(MacOS).	From	the	Bindings	panel,	select	tagline	and	click	Insert.	In	the	Property	
inspector,	select	Heading	3	from	the	Format	list;	press	Enter	(Windows)	or	Return	
(MacOS).	From	the	Bindings	panel,	select	desc	and	click	Insert.

Modifying	the	content	in	an	open	accordion	panel	is	very	straightforward.	But	how	do	
you	expose	a	closed	accordion	panel	for	editing?	Again,	Dreamweaver	provides	a	direct	
approach.

8	 Move	your	cursor	over	the	tab	of	the	bottom	accordion	panel;	when	you	see	an	eye	
icon	on	the	right	side	of	the	tab,	click	the	eye	icon	( ).	Select	the	placeholder	phrase	
Content	2	and	press	Delete	(Windows)	or	forward	delete	(MacOS).	From	the	Bindings	
panel,	select	work	and	click	Insert.

With	all	the	dynamic	content	in	place,	let’s	reapply	the	Spry	detail	region	attributes	to	
the	proper	places.	In	all,	there	are	three	tags	to	modify:	one	for	the	image	and	one	for	
each	of	the	accordion	panels.
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12	 Choose	Window	>	CSS	Styles.	Select	Attach	Style	Sheet	( )	from	the	bottom		
of	the	CSS	Styles	panel.	When	the	Attach	External	Style	Sheet	dialog	box	appears,		
click	Browse.	In	the	Select	Style	Sheet	File	dialog	box,	navigate	to	the		
lesson09	>	css	folder,	select	myAccordion.css	and	click	OK	(Windows)	or	Choose	
(MacOS).	Leave	the	other	settings	at	their	default	and	click	OK.

The	external	CSS	file	includes	several	rules	that	change	the	accordion	panel	tab	
background	colors	and	add	a	bit	of	padding	to	the	content	itself.	The	final	touch	is	to	
reformat	the	accordion	panel	labels.

13	 Place	your	cursor	in	the	top	accordion	panel	label	About	the	company.	From	the	
Property	inspector,	choose	Heading	3	from	the	Format	list.	Repeat	this	operation	for	the	
bottom	accordion	panel	label.

The	directional	arrows	are	background	images	which	have	been	applied	to	the	h3	
style;	a	rendering	bug	prevents	the	white	arrows	from	appearing	in	Design	view	on	the	
Macintosh—they	will,	however,	appear	when	previewed	in	your	browser.	This	page	is	
now	ready	for	preview	and	interaction.
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14	 Choose	File	>	Save.	When	the	Copy	Dependent	Files	dialog	appears,	click	OK.	
Press	F12	(Windows)	or	Option+F12	(MacOS)	to	preview	the	page	in	your	primary	
browser.	Select	the	second	data	row	from	the	master	data	table,	Company	Anon.	Review	
the	content	in	the	top	accordion	panel	and	then	click	the	bottom	accordion	panel	tab	to	
display	its	content.	Click	any	other	data	row	to	reveal	new	images	and	content.	When	
you’re	done,	close	your	browser	and	return	to	Dreamweaver.

The	top	accordion	panel	shows	by	default.

15	 Click	the	bottom	accordion	panel	to	see	its	contents.

In	the	next	exercise,	you’ll	take	advantage	of	the	sophisticated	JavaScript	functionality	
available	in	Spry	effects.
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4	 In	the	Highlight	dialog	box,	choose	h1	“headline”	from	the	Target	Element	list.	In	
the	Effect	duration	field,	enter	3000.	Click	the	End	Color	color	swatch	and,	with	the	
eyedropper	tool,	select	the	yellow	color	block	in	the	second	column	from	the	left.	Left	
the	other	settings	at	their	default	and	click	OK.

The	Highlight	behavior	can	be	applied	to	almost	any	HTML	object	(except	for	those	
related	to	frames	or	the	body	tag	itself)	as	long	as	the	object	has	a	valid	ID	attribute.	In	
this	example,	the	<h1>	tag	with	the	ID	of	#headline	is	targeted	and	the	effect	duration	is	
set	to	3	seconds	with	a	yellow	highlight.

5	 In	the	Behaviors	panel,	select	the	newly	entered	behavior.	Choose	onLoad	from	the	
Event	list	adjacent	to	the	Highlight	behavior	to	change	the	event	from	onClick.	Select	
the	Highlight	behavior	and	click	Up	( )	to	move	the	behavior	before	the	Preload	Images	
behavior.

By	moving	the	Highlight	behavior,	you’re	setting	up	the	behavior	to	trigger	as	soon	as	
the	rest	of	the	page	is	loaded	and	not	wait	until	all	rollover	and	other	initially	hidden	
page	images	are	preloaded.	
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  Labels for text � elds are, typically, placed before the � eld itself; this setting, however, is 
irrelevant since you’ll be moving the labels in just a moment.

� e  Access key � eld de� nes which key, when pressed in combination with the browser’s 
modi� er, gives focus to that � eld. For example, if a page visitor using Internet Explorer 
(version 6 or higher) presses Alt+c while browsing this page, the company � eld would 
be selected and ready for input. You’ll be assigning individual access keys for all the 
form elements on this page.

Note: � e access modi� er for Firefox is Shi� +Alt and for Safari, it is the Control key.

� e  Tab Index is another accessibility aid.  � e Tab Index determines the order in which 
the various form � elds receive focus when the Tab key is pressed. � e lowest number on 
the page is the � rst to receive focus, followed by the next highest number and so on. 

  It’s a good idea to initially enter Tab Index values in a multiple of ten (10, 20, 30, etc.) 
to allow for other form � elds to be inserted later without renumbering the entire form.

7 Place your cursor in the text Company Name and, from the Tag Selector, choose 
<label>. Drag the selection to the � rst table column in the same row. 

8 Choose File > Save.
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13	 Place	your	cursor	in	the	text	Username	and,	from	the	Tag	Selector,	choose	<label>.	
Drag	the	selection	to	the	first	column	in	the	same	row.	

14	 Move	your	cursor	over	the	username	text	field	until	the	Spry	Textfield	tab	appears;	
click	the	tab	to	select	the	object.	

15	 In	the	Property	inspector,	select	the	Validate	on	Blur	option	and	enter	6	in	the	Min	
Chars	field	and	press	Tab.

Dreamweaver	displays	a	new	preview	state	and	accompanying	error	message.	Let’s	
tighten	up	that	message	a	bit.

16	 Select	the	default	error	message,	Minimum	number	of	characters	not	met,	and	
press	Delete	(Windows)	or	forward	delete	(MacOS).	Enter	6 or more characters.

Finally,	let’s	customize	the	required	error	message	as	before.

17	 Move	your	cursor	over	the	username	text	field	until	the	Spry	Textfield	tab	appears;	
click	the	tab	to	select	the	object.	From	the	Preview	states	list	of	the	Property	inspector,	
choose	Required.	Select	the	default	error	text	next	to	the	field,	A	value	is	required,	and	
press	Delete	(Windows)	or	forward	delete	(MacOS).	Enter	Required.

18	 Choose	File	>	Save.

The	form	is	beginning	to	take	shape!	In	the	next	exercise,	you’ll	enter	another	type	of	
text	field,	the	password	field.
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1	 If	necessary,	re-open	the	media_start.htm	file	worked	on	in	the	earlier	exercise	by	
double-clicking	its	entry	in	the	Files	panel.

2	 Select	the	image	placeholder	Flash_Video	and	press	Delete	(Windows)	or	forward	
delete	(MacOS).

3	 From	the	Common	category	of	the	Insert	bar,	choose	Flash	Video	( )	from	the	
Media	menu	button.

4	 When	the	Insert	Flash	Video	dialog	box	appears,	make	sure	Video	Type	is	set	
to	Progressive	Download	Video.	Click	Browse	and	in	the	Select	Flash	Video	dialog,	
navigate	to	the	lesson11	>	assets	folder	and	choose	realty_park.flv;	click	OK	(Windows)	
or	Choose	(MacOS).

Note: If you ever have occasion to work with streaming video, you’ll notice a different set of 
options after selecting that video type.

The	video	controls	are	maintained	in	a	separate	file	known	as	a	skin.	Dreamweaver	
includes	nine	different	skins	to	choose	from.	Let’s	select	one	that	overlays	the	video	and	
appears	only	when	the	site	visitor’s	mouse	is	over	the	video.
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5	 If	necessary,	choose	Window	>	Properties	to	display	the	Property	inspector.	In	the	
Width	field,	enter	364	and	press	Tab.	In	the	Height	field,	enter	295	and	press	Tab.

The	movie	resizes	and	now	works	within	the	layout.	Now,	let’s	begin	to	set	the	
parameters	for	your	slide	show,	starting	with	the	color	scheme.

6	 In	the	Flash	elements	panel,	select	the	captionColor	color	swatch.	With	the	
Eyedropper	tool,	sample	the	dark	blue	color	at	very	bottom	of	the	navigation	bar.

By	sampling	colors	from	your	layout,	you	begin	to	incorporate	the	image	viewer	into	
your	page;	the	resulting	color	should	be	#046280.	Once	you’ve	identified	one	color,	it’s	
easy	to	apply	that	color	to	other	properties.

7	 Click	the	frameColor	color	swatch	and	use	the	Eyedropper	tool	to	sample	the	
captionColor	color	swatch.	Repeat	this	process	for	the	titleColor	property.	If	your	
Flash	element	panel	is	too	near	the	bottom	border,	the	color	picker	will	obscure	the	
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upper colors when opened; reposition the panel a bit higher to access the proper color 
swatches.

Let’s continue the customization by specifying new font sizes.

8 Change the captionSize value from 10 to 14 and press Tab. Repeat this change for 
the titleSize value so that both are 14.

Some Flash elements properties, like frameShow, use lists to present a limited number 
of options.

9 From the list next to frameShow, choose (Yes).

Other properties, like imageCaptions and imageLinks, must be able to accept multiple 
values; these values are stored in an array. Flash elements rely on a special dialog box to 
accept these array values. Let’s see how they work.
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In this lesson, you’ll learn how to publish your Web site to the Internet and do 
the following:

• Define a remote site.

• Check pages for browser compatibility.

• Validate pages.

• Put files on the Web.

• Get pages from the Web.

This lesson will take about 90 minutes to complete.  Be sure you have copied 
Lessons/Lesson12 from the Adobe Dreamweaver CS3 Classroom in a Book 
CD to your hard drive before beginning. As you work on this lesson, you’ll 
overwrite the start files. If you need to restore the start files, copy them again 
from the CD.

Defining a remote site
Dreamweaver is based on a two site system. One site is set up on a folder on 
your computer and is known as a local site. All work in the previous lessons 
has taken place in your local site. The other site is established in a folder on 
a Web server on another computer: this is the remote site. The remote site is 
generally connected to the Internet and publicly available.

Dreamweaver provides a number of ways to connect to a remote site:

• FTP – Short for File Transfer Protocol, FTP is the standard method for 
connecting to hosted Web sites.

• Local/Network – A local or network connection is most frequently used 
when an intermediate Web server, called a staging server, is employed. Files 
from the staging server are then published to an Internet connected Web 
server.

Publishing to the Web
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