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Transcribing Audio with Soundbooth
Soundbooth offers a very useful option that recognizes speech and translates 
it into text. The accuracy of this transcription can teeter-totter between being 
incredibly accurate to not very accurate. There are a few factors you can 
infl uence to improve the accuracy of the text:

■ Use a professional-quality microphone to get a cleaner audio signal.

■ Try to minimize or remove background noise.

■ Isolate the voice from music or sound effects to make the transcription 
more accurate.

■ Encourage the speaker to clearly pronounce words.

You will fi nd that you’ll generally have to do some cleanup after the auto-
matic transcription process. Fortunately, Soundbooth makes cleanup easy.

1. Copy the Chapter_14 Project Files folder from the DVD to a local hard 
drive.

2. Launch Soundbooth, and then choose Window > Workspace > Edit Audio 
to Video to place Soundbooth in a state to work with video fi les.

3. Choose Window > Metadata to view the Metadata panel.

The Metadata panel is your starting point for speech transcription. Run-
ning the transcription function takes a while, but when it’s fi nished, all 
metadata for clips will be searchable from the Metadata panel. Fortu-
nately, the process can run in the background, which means you can 
still edit or perform other tasks. The Metadata panel also allows you to 
search by any word or phrase within the clip.

4. Choose File > Open and open the fi le gasPrices_original.f4v from the 
Chapter_14 Project Files folder.

You can open any standard type of video fi le in Soundbooth, such as 
QuickTime, AVI, F4V, or FLV.

5. Click Play to preview the fi le.

Become familiar with the short news story. You will optimize this clip 
for the Web and make it more accessible for the news channel’s Web site.

● NOTE: Cleaning 
Up Audio

The clearer the audio 
is, the more accurate 
the transcription will 
be. If you have noise 
in the sound track, 
consider cleaning 
up the audio first. In 
Soundbooth, choose 
Tasks > Clean Up 
Audio from Sound-
booth’s menu. You 
can use the Clean 
Up Audio section to 
adjust the param-
eters and preview 
the changes until the 
audio sounds clean. 
For more informa-
tion, see Sound-
booth’s online help.

● NOTE: Go for Max

Ultimately, the video 
you are transcribing 
will get recompressed 
as a Flash Video 
file. In this case, we 
are using a precom-
pressed file to save 
space on the book’s 
DVD. You should use 
the original-sized file 
from Premiere Pro or 
After Effects when-
ever possible.
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Speech Transcription Options
To improve the accuracy of the transcription, Soundbooth needs additional 
information from you. Soundbooth can currently access seven different 
language libraries, and we expect this list to expand. You’ll fi nd that many 
languages offer subtle varieties, such as English offering localizations for 
Australia, Canada, the United Kingdom, and the United States.

1. Click the Transcribe button at the bottom of the Metadata panel.

2. Select the appropriate language. For this clip choose English - U.S.

3. Choose a Quality setting.

Adobe offers two quality choices for the transcription. The default choice 
is High (Slower), which will take longer to process the fi les but offers 
signifi cantly better translation. The second choice, Medium (Faster), 
should only be used when you are very tight on time. The results are less 
accurate but do process more quickly.

In our tests, we used a 2.4 GHz Intel Core 2 Duo processor with 4 GB of 
RAM. The High method resulted in a ratio of 1.8, meaning the runtime of 
the clip multiplied by 1.8 equals the approximate processing time. The 
Medium method was nearly four times faster with a ratio of approxi-
mately .5.

Since you have some time and it’s a short clip, choose the High quality 
method.

4. Leave the Identify Speakers option deselected since there is only one 
voice in this news story.

The transcription option can attempt to identify different speakers in a 
clip. In the Speech Transcription Options dialog, you can select Identify 
Speakers. This takes longer to process but will attempt to create separate 
transcripts for each person. This method can be inaccurate, so only use it 
if you have a long clip with multiple voices or want to export the tran-
script for others to view.

5. When you’re ready to submit your clip, click OK.

Depending on the speed of your computer, Soundbooth should take 
about three minutes to process the clip. While that’s happening, let’s 
take a look at the road ahead.

▲ TIP: Learn 
Additional 
Languages

To download all the 
additional language 
packs, go to www.
adobe.com/prod-
ucts/soundbooth/
speechtotext.
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Cleaning Up the Transcript
When the transcript is complete, you can edit it. This means you can fi x any 
words that you know are spelled wrong as well as add punctuation. While 
this involves a bit of manual labor, Soundbooth will have done 60–95 percent 
of the work for you.

Here is the script that the reporter read:

[Reporter] Despite the decreasing price of oil per barrel, gas prices at the 
pump continue to rise. With the onset of the economic crisis, oil companies 
and refi neries have felt this pinch, forcing them to cut back on production. 
This cutback has ultimately trickled down to the consumers, causing higher 
prices at the pump. While commuters are grumbling about increasing gas 
prices, there doesn't seem to be any sign of a slowdown. Industry analysts 
predict prices will continue to rise for the next three months at least.

1. Compare the preceding script to the Soundbooth transcription.

Notice that Soundbooth was very accurate. Only two words were missed 
and one phrase was improperly transcribed. This is a very good start, 
but it’s still not perfect. Some of the words are wrong, and there’s no 
punctuation.

2. Double-click on the word increasing (in the fi rst line). Change the word to 
decreasing.

3. Let’s add the fi rst punctuation mark. Double-click the word barrel (in the 
fi rst line). Press the arrow key to move to the end of the word and type a 
comma to insert the natural pause.
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Transcribe with Adobe Media Encoder

If you have several clips to transcribe, we recommend using the Adobe 
Media Encoder. This powerful tool is normally used to convert audio and 
video files to many different formats used for tasks like DVD authoring and 
Web distribution.

You can import an entire folder of media to transcribe. In the Adobe Media 
Encoder CS4 application, click the Add button in the main window. Then nav-
igate and select multiple clips in a folder (hold down the Shift key to choose 
more than one clip). Next, specify Speech Transcription from the Format but-
ton. You must then specify options by clicking the word Custom (if you want 
to adjust multiple clips at once, Shift-click to select them all before clicking 
Custom). Select the Speech Params tab and set the Language, Quality, and 
Identify Speakers options using the aforementioned advice.

4. The phrase “down to the consumer is causing” has a few errors, so 
change the word consumer to consumers. Then, right-click the word is 
and choose Delete Word.

5. Continue editing the transcript, adding letters, merging or deleting 
words, and adding punctuation as needed. It should only take you a few 
minutes to clean up the text. You can reference the following text while 
making the fi xes. The characters in red indicate a change to the tran-
script. You can use the Tab key from word to word in the transcript and 
press Return/Enter to edit:

[Reporter] Despite the decreasing price of oil per barrel, gas prices at the 
pump continue to rise. With the onset of the economic crisis, oil companies 
and refi neries have felt this pinch, forcing them to cut back on production. 
This cut back has ultimately trickled down to the consumers, causing higher 
prices at the pump. While commuters are grumbling about increasing gas 
prices, there doesn't seem to be any sign of a slowdown. Industry analysts 
predict prices will continue to rise for the next three months at least.

Exporting a Transcript as XML
After you’ve cleaned up the transcription, you can export it as an XML fi le. 
As you’ll see in the next section, this XML fi le will become useful in several 
ways, notably for embedding cue points and making videos searchable.

1. From Soundbooth’s menu, choose File > Export > Speech Transcription.

2. Save the fi le as gas.xml in the Chapter_14 Project Files folder. (The save is 
very fast; blink and you’ll miss it.)

▲ TIP: Take Your 
Transcripts with You

The entire transcript 
can be copied by 
selecting it all , right-
clicking it, and then 
choosing Copy All. 
Additionally, you can 
include the tran-
script file in the final 
export if you
are sending your 
video to the Web
via Flash Video.
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If you open the fi le in a text editor, it will look like this.

Importing XML Cue Points
You just exported the XML fi le out of Soundbooth, but now you’ll bring it right 
back in. You can use the XML to create cue points (which Soundbooth calls 
“markers”) on the video’s Timeline. These cue points are critical because they 
allow Flash to associate the transcript with the video fi le for navigation.

1. Choose File > Import > Markers.

2. Navigate to the Chaper_14 Project Files folder and select the recently cre-
ated gas.xml. Click Open.

Several markers are added to the Timeline

Here’s Soundbooth’s 
Timeline with the 
imported markers. These 
will become cue points 
in the rendered file.



 CHAPTER 14: MAKING VIDEO ACCESSIBLE  7

Excerpt from After Effects for Flash | Flash for After Effects Copyright © 2009. Used with permission of Pearson Education, Inc.
and Adobe Press. For ordering information, please visit www.peachpit.com/AEFlashCS4

Rendering an FLV
After the markers have been added, it’s time to save out a fi le that is ready for 
Flash. This process is very simple.

1. Choose File > Save As. 
Name the fi le gas. Target the 
Chapter_14 Project Files 
folder. Choose FLV | F4V (*.f4v) 
form the Format pop-up 
menu. Click Save.

The Export Settings window 
opens. You are essentially 
rebundling the compressed 
fi le so the markers get added 
into the fi le.

2. Choose FLV - Same As Source Flash 8 and Higher from the Preset 
pop-up menu.

3. Change Bitrate Encoding to VBR.

4. Click OK to render out a fi le.This process takes a few minutes as the fi le 
re-encodes. When the process is done, quit Soundbooth.

Now that you have an XML fi le and an FLV fi le with markers, you can create 
accessible video.
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● NOTE: Evolving 
Files

The provided HTML 
files are still in an 
evolving develop-
mental stage. Check 
www.peachpit.com/
AEFlashCS4 for future 
improvements.

Making Searchable Video 
We’ve placed an HTML (Web page) application on this book’s Web site at 
www.peachpit.com/AEFlashCS4. This application allows you to make your 
video searchable as if it were a text document. You’ll need to make a couple of 
simple edits, and then everything will be good to go. 

Customizing Adobe’s Searchable 
Video Application

Adobe has created a Web application that allows users to search through 
your Flash video using transcript words as search terms. All the code needed 
to make this work is in the VideoSearch folder. You will need to customize 
this code so that it points to your video and transcript fi les. To do so, follow 
the steps below.

1.  Add your video and transcript fi le to the VideoSearch/assets folder.

For this example, place the gas.fl v and gas.xml fi les you created earlier.

2. Open the VideoSearch/searchableVideoPrefs.xml fi le in a text-editing 
application, such as TextEdit on the Mac or Notepad on a Windows 
machine.

3.  In the searchableVideoPrefs.xml fi le, you’ll see a few lines of code that 
look like this:

<!--<sourceURI>assets/asset_name.flv</sourceURI> -->
<sourceURI>assets/asset_name.flv</sourceURI>  
<!--<sourceURI>rtmp://[theserver]/[theapplication]/asset_name.
➥flv</sourceURI> -->
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Edit the text called asset_name.fl v so that it matches the name of your
media fi le.  In this example, use gas.fl v. You can also use an “absolute
URL” to link to a video on the Web, such as:

<sourceURI>http://www.mySite.com/videos/myVideo.flv</sourceURI> 

4. Next, you’ll need to specify the name of the XML fi le. You’ll edit the code
that looks like this:

<!--<transcriptLocation>assets/asset_name.xml</transcriptLocation>-->
<transcriptLocation>assets/asset_name.xml</transcriptLocation>

Edit the text called asset_name.xml so it matches the name of your
media fi le.  In this example, use gas.xml. 

In the searchableVideoPrefs fi le, you’ll also see options for skinning the
video. If you don’t like the look of the video controls, you can change
the skin reference (<fl vplayerskin>skins/SkinUnderPlayStopSeekMute-
Vol.swf</fl vplayerskin>) to one of the other skins included in the Video-
Search/skins folder. These are the same skins you see in Flash’s Video
Import Wizard.

5. By default, the application will not allow searches for words of less than
fi ve characters. This excludes simple, common words such as “the” and
“and”. You can modify this setting by changing the “5” in this preference:

<minwordLength>5</minwordLength>

Testing the HTML
After the assets are loaded, you can simulate the searchable video. But fi rst
you’ll need to get the simulation running with a few preferences tweaks.

1. Start your Web browser.

2. Open the fi le index.html. from the VideoSearch folder.

The application won’t work at fi rst because it’s running on your hard
drive, not on the Web. Flash is very leery of interactions between HTML
and Flash movies that run on your desktop, since they might be made
by “hackers” who are trying to damage your system. In this case, the
concern is unwarranted.

3. Right-click on the video player and choose Settings.
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4. In the Adobe Flash Player Settings dialog, 
click the Advanced button.

A new window opens in the Web browser 
that offers links to the Settings panel. Again, 
to protect Flash from hackers, you’ll need to 
manually navigate to this setting.

5. In the Settings Manager, click the Global Security Settings Panel 
hyperlink.

6. On the Global Security Settings tab, click the Edit Locations drop-down 
menu, and then choose the Add Location option.
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7. Add the fi le video_player.swf (Chapter_14 Project Files > Video Search > 
video_player.swf).

8. Reload the SearchableVideo+Keywords.html Web page.

9. Try typing gas into the search form (a word that’s in the transcript),
and then click the Search button.

10. Once the video player has located cue points, click them to see the cue-
point metadata. 

11. Also, try clicking one of the Top Keywords to search for it in the video.


