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U
sing the Toolbox

Tools
Using the Toolbox 
The Toolbox contains 74 tools that are used
for object creation and editing. If the Toolbox
is hidden, choose Window > Tools to display
it. To move the Toolbox, drag the top bar.
Click once on a visible tool to select it. Press
on any tool that has a tiny arrowhead to
choose a related tool from a pop-out menu.
When you double-click some tools, an
options dialog box opens for the tool. 

To create a standalone tearoff toolbar �–�,
release the mouse when it’s over the vertical
tearoff bar on the far right side of any tool
pop-out menu. Move a tearoff toolbar by
dragging its top bar. To restore a tearoff
toolbar to the Toolbox, click its close box.

To access a tool quickly, use its letter short-
cut (see the letters in gray on the next two
pages). Some tools can be accessed using a
toggle key (e.g., pressing Cmd/Ctrl accesses
the Selection tool when the Pen tool is 
chosen). You’ll learn more toggles later.

To turn tool pointers into crosshairs for pre-
cise positioning, check Use Precise Cursors in
Illustrator (Edit, in Windows) > Preferences >
General. Or press Caps Lock to turn a tool
pointer into a crosshair temporarily.

➤ You’ll probably want to leave Disable
Warnings unchecked in Preferences >
General, at least if you’re new to
Illustrator. With this option unchecked,
an alert prompt will appear when a tool 
is used incorrectly.

This chapter is an introduction to Illustrator’s tools,
menus, palettes, and measurement systems. 

Note: If you’d like to glance onscreen at 
the features discussed in this chapter as you 
read, launch Illustrator and create a new 
document (see pages 39–41).
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Hide/show
Tab Hide/show all currently open 

palettes, including the Toolbox

Shift-Tab Hide/show all currently open 
palettes and tearoff toolbars, 
but not the Toolbox

Chris
Spo

llen

� Open a tearoff toolbar
by choosing a tearoff bar.

� A tearoff toolbar
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Lasso Q
Selects individual points or
segments by lassoing

Adobe Online access

Rectangle M
Draws rectangles and
squares

Pencil N
Creates freehand-style
lines

Scale S
Enlarges or shrinks objects

Free Transform E
Rotates, scales, reflects, shears,
distorts, or applies perspective

Column Graph J
Creates graphs

Gradient G
Changes the direction of 
existing gradients

Blend W
Creates shape and color blends
between objects

Scissors C
Cuts paths

Zoom Z
Changes the magnification
of the illustration 

Swap Fill and Stroke Shift-X

Stroke X
Color that’s applied to the edge
of a path (click to activate)

None /
No stroke or fill

Full Screen Mode F

Full Screen Mode
with Menu Bar F

Y Magic Wand
Selects objects by color

Direct Selection A
Selects parts of objects

V Selection
Selects entire objects

P Pen
Draws curved and straight line

segments

\ Line Segment
Draws straight lines at any angle

B Paintbrush
Creates Calligraphic, Scatter,

Art, and Pattern brush strokes

R Rotate
Rotates objects

Shift-R Warp
Distorts shapes

Shift-S Symbol Sprayer
Sprays symbol instances

U Mesh
Creates and edits multicolored

mesh objects

I Eyedropper 
Samples paint and type attributes

Shift-K Slice
Defines slice areas

H Hand
Moves the artboard in the

document window

X Fill
The color, gradient, or pattern

that fills the inside of a path

D Default Fill and Stroke
(white fill, black stroke) 

> Gradient
Reapplies last gradient fill

< Color
Reapplies last solid color

stroke or fill

F Standard Screen Mode

The Toolbox
Note: To assign your own shortcuts
to tools, use the Keyboard Shortcuts
dialog box (see pages 526–528).

Type T
Creates and edits
horizontal type
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Graph tools

The tearoff toolbars

Drawing tools

Vertical
Path Type
Creates and
edits type
vertically
along a path

Vertical Area
Type Creates
and edits type
inside an object
vertically

Type on a Path
Creates and edits
type horizontally
along a path

Area Type Creates
and edits type inside
an object horizontally

Vertical Type
Creates and edits
vertical type

Group Selection
Selects whole groups

Convert
Anchor Point
Converts corner
points to curved,
and vice versa
Shift-C

Delete Anchor
Point -

Add Anchor
Point +

Arc Creates
curved line
segments

Spiral
Creates
spiral lines

Rectangular
Grid Creates 
rectangular grids

Polar Grid
Creates 
circular grids

Reflect Creates a mirror
image of an object O

Crystallize Wrinkle
Liquify tools Object creation tools

Twirl Pucker Bloat Scallop Rounded
Rectangle

Ellipse
L

Polygon Flare
Creates
lens flares

Star 

Erase 
Erases sections
of paths

Smooth 
Smooths paths

Symbol
StylerSymbol

Screener
Symbol
Stainer

Symbol
Spinner

Symbol
Sizer

Symbol
Scruncher

Symbol
Shifter

Symbolism tools

K Paint Bucket Fills objects with the
current paint or type attributes by clicking 

Measure
Measures the distance
between points

Shear 
Skews objects

Reshape
Reshapes 
sections of paths

Slice Select Selects slices Page Defines 
the printable area

Auto Trace
Traces object silhouettes

Knife
Carves up paths

Stacked
Column

Stacked
Bar

Line Area Scatter Pie RadarBar
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13 Resize box

The Illustrator screen in Macintosh

11 Status bar

4 Zoom

3 Minimize

1 Menu bar

2 Close

Status bar
pop-up menu

12 Scroll arrows

6 Rulers

8 Guide

Scratch area

Scroller

➝

➝

➝

➝

7c Page
boundary 

7a Imageable 
area boundary 

10 Zoom field
and pop-up menu

9c Swatches palette9b Pathfinder palette

9a Toolbox

On the screen

Document window

Scroll bar

5 Title bar, zoom level , color mode, and view
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1 Menu bar
Use the menu bar to open dialog boxes or
palettes or to choose commands.

2 Close button (red)
To close a document or a palette, click its
close button.

3 Minimize button (yellow)
Click the minimize button to shrink the 
document window to an icon in the Dock;
click the icon in the Dock to restore the 
document window to its previous size.

4 Zoom button (green)
Click a document window zoom button to
enlarge the window. Click again to restore
the window to its previous size. (Click a
palette zoom button to shrink the palette or
restore it to its previous size.) 

5 Title bar, zoom level, color mode, and view
The illustration’s title, zoom level, color
mode (CMYK or RGB), and view (Preview,
Outline, Pixel Preview, or Overprint Preview)
are listed on the title bar.

6 Rulers
The current position of the pointer is indicated
by a marker on the horizontal and vertical
rulers. Ruler increments can be displayed in 
any of these measurement units: points, picas,
inches, millimeters, centimeters, or pixels.

7a–c  Imageable area, artboard boundary,
and page boundary
The imageable area within the margin guides
is the area that will print on the paper size
currently selected in File > Print (General).
The artboard is the user-defined work area
and the largest possible printable area. The
nonprinting page boundary matches the 

current paper size. Objects located in the
area outside the artboard will save with the
file, but they won’t print.

8 Guide
Drag from the horizontal or vertical ruler 
to create a guide. Guides are used only for
aligning objects; they don’t print.

9a–c Palettes
Pathfinder and Swatches are five of 31 move-
able palettes that open from the Window
menu. The Toolbox contains 74 (yes, 74!)
drawing and editing tools, as well as color
controls and screen mode buttons.   

10 Zoom field
Enter a new zoom percentage in this field 
or choose a preset zoom percentage from the
pop-up menu.

11 Status bar
Depending on which category you choose
from the pop-up menu, the status bar displays
the name of the Current Tool, the current
Date and Time from System Preferences >
System > Date & Time, the Number of avail-
able Undos/Redos, or the Document Color
Profile. Option-press the status bar pop-up
menu to learn the Moon Phase, Shopping
Days ’til Christmas, and other vital statistics.

12 Scroll arrows
Click the downward-pointing scroll arrow 
to move the illustration upward in the docu-
ment window. Click the upward-pointing
scroll arrow to move the illustration down-
ward in the document window.

13 Resize box
To resize a document window, drag its resize
box diagonally.

Key to the Illustrator screen in Macintosh
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The Illustrator screen in Windows

16 Status bar

5 Application maximize button

6 Application minimize button

7 Application close box
4Title bar, zoom level,
color mode, and view

3 Menu bar

2 Document
Control menu

1 Application
Control menu 

Status bar pop-up menu

12 Toolbox

7 Document
close box

5 Document maximize button

Palettes

15 Zoom field
and pop-up menu

8 Rulers

➝

➝
➝

➝

➝10b Artboard 
and page
boundary

11Guide

13 Scroll
arrow

14 Resize box

9 Document minimize button

10a Imageable area boundary
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Illustrator Screen in W

indow
s

Key to the Illustrator screen in Windows

1 Application Control menu box
The Application Control menu box com-
mands are Restore, Move, Size, Minimize,
Maximize, and Close. 

2 Document Control menu box
The Document Control menu box commands
are Restore, Move, Size, Minimize, Maximize,
Close, and Next.

3 Menu bar
Use the menu bar to open dialog boxes or
palettes or choose commands.

4 Title bar, zoom level, color mode, view
The illustration’s title, zoom level, color
mode (CMYK or RGB), and view (Preview,
Outline, Pixel Preview, or Overprint Preview)
are listed on the title bar.

5 Maximize/restore down button
Click the document or application maximize
button to enlarge either window to fill the
available space completely. When a window
is maximized, the button turns into a restore
down button. Click this button to shrink the
window to its former size.

6 Application minimize button
Click the application minimize button to
shrink the application to an icon on the
taskbar. Click the icon on the taskbar 
to restore the application window to its 
previous size.

7 Close box
To close a document or a palette, click its 
close box.

8 Rulers
The current position of the pointer is indicated
by a marker on the horizontal and vertical
rulers. Ruler increments can be displayed in 
any of these measurement units: points, picas,
inches, millimeters, centimeters, or pixels.

9 Document minimize button
Click the document minimize button to shrink
the document to an icon at the bottom left
corner of the application window. To restore
the document to its previous size, double-
click the icon or click the restore up button.

10a–b  Imageable area, artboard boundary,
and page boundary
The imageable area within the margin guides
is the area that will print on the paper size
currently selected in File > Print (General).
The artboard is the user-defined work area
and the largest possible printable area. The
nonprinting page boundary matches the cur-
rent paper size. Objects outside the artboard
save with the file but don’t print.

11 Guide
Drag from the horizontal or vertical ruler 
to create a guide. Guides are used only for
aligning objects; they don’t print.

12 Toolbox
The Toolbox contains 74 (yes, 74!) drawing
and editing tools, as well as color controls
and screen mode buttons. It’s one of the 
31 moveable palettes that open from the
Window menu.  

13 Scroll arrows
Click the downward-pointing scroll arrow 
to move the illustration upward in the docu-
ment window. Click the upward-pointing
scroll arrow to move the illustration down-
ward in the document window.

14 Resize box
To resize a document window, drag its 
resize box diagonally or drag the edge of 
the window.

15 Zoom field
Enter a new zoom percentage in this field or
choose a preset zoom percentage from the
pop-up menu.

16 Status bar
Depending on which category you choose
from the pop-up menu, the status bar dis-
plays the name of the Current Tool, the cur-
rent Date and Time from the computer’s
internal clock, the Number of available
Undos/Redos, or the Document Color Profile
(RGB or CMYK). Alt-press the status bar
pop-up menu to learn the Moon Phase,
Shopping Days ’til Christmas, and other 
vital statistics.
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File menu Illustrator menu Edit menu

The Illustrator menus

Object menu Type menu Select menu 

In Windows, the
Preferences command 
is on the Edit menu 
and the Exit command
is on the File menu.
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enus

View menuFilter menu Effect menu

Window menu

Help menu

The Window > Cascade,
Tile, and Arrange Icons
commands are available
only in Windows.

The Help > About
Illustrator and About 
Plug-ins commands are
available only in Windows.



Using dialog boxes
Dialog boxes are like fill-in forms with multi-
ple choices. They are opened from the menu
bar or via shortcuts. 

In Windows: To activate a menu, type Alt
plus the underlined letter, then release Alt and
type the underlined letter on the submenu.

Some modifications are made by entering a
number in an entry field. Press Tab to high-
light the next field in a dialog box; press
Shift-Tab to highlight the previous field.
Press or click on a pop-up menu to choose
further options.

Click OK or press Return/Enter to accept
modifications and exit a dialog box. To 
cancel out of a dialog box, click Cancel or
press Esc.

Many Illustrator dialog boxes have a
Preview option that when checked will apply
the effect while the dialog box is open. Take
advantage of this great timesaver. 

Illustrator dialog boxes, like all the other 
features in the program, function the same
way on the Mac as in Windows, though they
look slightly different because the graphic
interfaces are different.
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Type a number into a
field. Press Tab to jump

from one field to the next.

Click a check box on
or off. A “√” means

that option is on.

Click OK or press
Return/Enter to exit a
dialog box and accept
the new settings.

Click Cancel to exit
a dialog box with no
modifications taking
effect.

Check Preview to
preview new settings
in your illustration
right away.

A dialog box in Macintosh

A dialog box in Windows

In Windows, you can type an underlined letter
to activate that field (e.g., “U” for “Uniform”).
If a field is already highlighted, type Alt plus
the underlined letter. In Windows XP, you 
have to press Alt for the underlines to show up.
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U
sing the Palettes

Using the palettes
Illustrator has 31 movable palettes, all of
which can be opened from the Window
menu, and many of which can be opened 
and closed via assigned shortcuts. To save
screen space, the palettes are organized into
these default groups: Appearance/Layers;
Actions/Links; Navigator/ Info; Character
Styles/Paragraph Styles; Swatches /Color;
Document Info/Attributes; Flattener Preview;
Glyphs; Stroke/Gradient /Transparency;
Tabs; Graphic Styles /Brushes/Symbols;
Magic Wand; Transform/Align/Pathfinder; 
SVG Interactivity/Variables; Character/
Paragraph/Open Type; and Tools. The
palette name you choose from the Window
menu will appear in front within its group
when the group opens.

You can compose your own groups or sepa-
rate a palette from its group. To separate a
palette, drag its tab (palette name) away from
the group �–�. To add a palette to any
group, drag the tab over the group. 

➤ When you compose a palette group, start
with one of the resizable palette windows.  

� Now the Symbols palette is on its own.

� To separate a palette from its group, drag the
tab (palette name) out of the group.

� To dock palettes together, drag the
tab name of one palette to the bottom 
of another palette, and release the 
mouse when the thick black line appears
across the bottom of the target palette.

To dock (hook up) one palette to the bottom 
of another palette or palette group, drag the
tab to the bottom of the target palette, and
release the mouse when the thick black line
appears �. To undock, drag a palette tab
out of the dock group.

To display an open palette at the front of its
group, click its tab. Palettes with an up/down
arrow on the tab (such as the Color palette)
have more than one panel. Click this arrow
or the tab name to cycle through the palette
configurations: tab only, two option panels,
or one option panel. Another way to display
a full palette is to choose Show Options
from the palette menu. To shrink a palette
group to just the tabs, on the Mac, click the
palette zoom button (green) in the upper 
left corner; in Windows, click the minimize/
maximize button. Click the button again to
restore the palette’s previous size.

➤ Press Tab to hide/show all currently open
palettes, including the Toolbox; press
Shift-Tab to hide/show all open palettes
except the Toolbox. 

Palettes that are open when you quit/exit
Illustrator will reappear in the same location
when the application is relaunched.

Use the palette
menus to access
additional 
commands!
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The color controls
The current fill and stroke colors display in
color squares on the Toolbox � and on the
Color palette �. The Color palette displays
the color model and breakdown of the fill 
or stroke in the currently selected object or
objects; use it to choose Web-safe colors or
process colors or to adjust global process or
spot color tints. 

The Stroke palette displays the weight and
style of the stroke in the currently selected
object or objects, and can be used to change
those attributes. If no object is selected,
changes made on the Color or Stroke palette
will apply to subsequently drawn objects. 

Color palette F6
Use the Color palette to mix, choose, and
switch between fill and stroke colors.
Choose a color model for the palette from
the palette menu. Quick-select a color, black,
white, or None from the bar at the bottom
of the palette.

� Fill color, 
pattern, or gradient 

Stroke color 

Whichever box (Fill or Stroke) is 
currently active (is on top on the Color
palette and the Toolbox) will be affected
by changes on the Color palette.

Stroke palette F10
Use the Stroke palette to edit the stroke
weight and style of the selected object or
objects, and to create dashed lines or frames.

Swap Fill
and Stroke 

None (no
color)(Reapply last)

Gradient

Default Fill 
and Stroke

(Reapply last fill or
stroke) Color

Spectrum

Stroke Weight
(thickness)

Join (bend) styles

Fill

Stroke

None

Out of Web Color Warning
(click box for Web-safe substitute) 

Out of Gamut Warning
(click box for printable substitute) 

Dashed Line
segment (dash) and

gap lengths (spacing
between dashes)

Cap (end) styles

�
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Sw

atches Palette; G
radient Palette

Gradient slider 

Starting color stop Ending color stopAn added color stop

The gradient Type:
Linear or Radial

The Midpoint 
diamond marks
the point where
two adjacent 
colors are at an
equal, 50/50 mix. 

Gradient palette
Use the Gradient palette to create new gradi-
ents and edit existing gradients. You can
move a color by dragging its stop; choose a
different color for a stop from the Color
palette; click below the gradient slider to add
a new color; move a midpoint diamond to
adjust how adjacent colors are distributed; 
or change the gradient angle.

A global process color

A nonglobal process color

Use these buttons to control
which categories of swatches
are displayed on the palette.

All Colors Gradients Patterns New
Swatch

Delete
Swatch

Swatches palette
Use the Swatches palette to choose and store
default and user-defined colors. If you click a
swatch, it becomes the current fill or stroke
color, depending on whether the Fill or
Stroke box is currently active on the Toolbox
and Color palette. 

Drag from the Fill or Stroke color box on the
Toolbox or the Color palette to the Swatches
palette to save that color as a swatch in the
current file. You can merge swatches and 
perform other tasks via the palette menu.

A spot color
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Font 

The Language for hyphenation
for the current document

Leading 

Vertical Scale 

Kerning Tracking

Character
Rotation

Character palette
Use the Character palette to apply type
attributes: font, size, leading, kerning,
tracking, horizontal scale, vertical scale,
baseline shift, character rotation, and 
foreign language options. To apply an
attribute to currently highlighted text,
choose a value from the pop-up menu; or
click the up or down arrow; or enter a
value in the field and press Return/Enter. 

Font Style

Horizontal Scale 

Font Size

Baseline Shift

Text-related palettes

The palettes that are used for formatting text 
are opened from the Window > Type submenu:
Character, Character Styles, Glyphs, OpenType,
Paragraph, Paragraph Styles, and Tabs. Four of
these palettes can be opened via a shortcut:

Character Cmd-T/Ctrl-T 

OpenType Cmd-Option-Shift-T/
Ctrl-Alt-Shift-T 

Paragraph Cmd-Option-T/Ctrl-Alt-T

Tabs Cmd-Shift-T/Ctrl-Shift-T

new

new

new
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Character Styles Palette; G

lyphs Palette

Character Styles palette
Character styles are collections of character
attributes, such as font, point size, leading,
tracking, and kerning. Unlike paragraph
styles, which are applied to whole para-
graphs, character styles are applied to bits
and pieces here and there—bullets, boldfaced
words, italicized words, large initial caps, etc.
When character styles are applied to high-
lighted text within a paragraph, multiple
attributes are applied at a time; when you
edit a style, the text that it’s associated with
updates accordingly. Using the Character
Styles palette, you can create, apply, edit, 
store, duplicate, and delete character styles.

Glyphs palette
Using the Glyphs palette, you can find out
which character variations (alternate glyphs)
are available for any given character in a 
specific font, and use the palette to insert
glyphs from any font into your text (some
of which can’t be inserted via the keyboard).

new

New Style Delete
Selected
Styles

Font Pop-up showing alternate glyphs
for an individual character

Font Style Zoom Out Zoom In

Via the Show pop-up menu, you can 
control whether the palette displays glyphs
of a specific category or for an entire font. 

A character
style

new
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OpenType palette
Illustrator CS supplies you with 24 Roman-
language OpenType font families, which can
be used on both the Mac and Windows sys-
tems. Those fonts that contain a particularly
large assortment of alternate glyphs are
labeled “Pro.” By clicking a button on the
OpenType palette, you can specify which
alternate characters (glyphs) will be used
automatically in your text, such as ligatures,
swashes, titling characters, stylistic alternates,
ordinals, and fractions. You can also use the
palette to specify options for numerals, such
as style (e.g., tabular lining or oldstyle), and
position (e.g., numerator, denominator,
superscript, or subscript).

Paragraph palette
Use the Paragraph palette to apply specifica-
tions that affect entire paragraphs, including
horizontal alignment, indentation, space
before/after paragraph, word spacing, letter
spacing, hyphenation, and hanging punctuation.

Horizontal Alignment buttons

Left Center Right

Justify
Last Left

Justify
Last
Right

Justify
Last
Center

Justify
All

First-Line Left Indent

Left Indent Right
Indent

Space
After
Paragraph

Space Before Paragraph

Automatic Hyphenation

Standard
Ligatures

Contextual
Alternates

Discretionary
Ligatures

Stylistic
Alternates

Titling
Alternates

Ordinals

Fractions

Swash

Style and
position
options
for
numerals

new
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Paragraph Styles Palette; Tabs Palette

Paragraph Styles palette
A paragraph style is a set of paragraph speci-
fications (e.g., horizontal alignment, indenta-
tion, space before paragraph, word spacing,
letter spacing, hyphenation, and hanging
punctuation) and character attributes, such as
font and point size. When a paragraph style
is applied, all currently selected paragraphs
are reformatted; when a style is edited, the
paragraphs that it’s associated with update
accordingly. Using styles makes light work 
of formatting type and helps ensure that it
looks uniform. You can create, apply, edit,
store, duplicate, and delete paragraph styles
by using the Paragraph palette.

Tabs palette
If you want to create perfectly aligned
columns of text, you need to use tabs. Using
the Tabs palette, you can insert, move, and
change the alignment for custom tab mark-
ers, as well as specify optional leader and
align-on characters. 

A tab marker

Optional
Leader
character

Optional
character to
Align On

A selected tab marker Position Palette
Above Text

New Style Delete
Selected
Styles

A paragraph
style

Numeric Location of the 
currently selected tab marker

Left-, Center-, Right-, 
and Decimal-Justified

alignment buttons (or Top-
and Bottom-Justified

buttons for vertical type)

new

new
new

new
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Layers palette F7
Use the indispensable Layers palette to add
and delete layers and sublayers from a docu-
ment. You can also use this palette to select;
restack; hide/show; lock/unlock; change the
view for; create a clipping set for; target; or
dim (for tracing) a layer, sublayer, group, or
individual object. When your illustration is
finished, it can be flattened into one layer, or
the objects can be released to separate layers
for export to an animation program.

Info palette
If no object is selected in the current docu-
ment, the Info palette will list the horizontal
and vertical location of the pointer in the doc-
ument window (for most tools). When an
object is selected, the palette lists the location
of the object on the page and the object’s
width and height. When a type tool and type
object are selected, the palette displays type
specifications. The Info palette opens automat-
ically when the Measure tool is used, and lists
the distance and angle calculated by that tool.

Click an eye icon to 
hide that layer or object; 

click again to redisplay it.

Selection
square

A sublayer

New
Sublayer

New
Layer

Delete
Selection

Locked layers, 
sublayers, groups, or

objects are uneditable.

Horizontal (X) and 
Vertical (Y) location of the
currently selected object

Stroke info (color breakdown,
or pattern or gradient name)

Fill info (color breakdown,
or pattern or gradient name)

Make/Release
Clipping Mask

Click this icon to target an object
or group in order to edit its
appearances; drag this icon to
move the object’s appearance.

Current Layer
indicator

Object Width (W)
and Height (H)
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Align Palette; Transform

 Palette

Align palette Shift-F7
Buttons on the top two rows of the Align
palette let you align and/or distribute two or
more objects along their centers or along
their top, left, right, or bottom edges. Buttons
at the bottom of the palette let you equalize
(redistribute) the spacing between three or
more objects.

Transform palette Shift-F8
The Transform palette displays location,
width, and height information for the currently
selected object. You can also use the palette to
move, scale, rotate, or shear a selected object
or objects.

Reference Point 
(the part of the
object that the

palette values are
calculated from )

The location of the currently selected
object on the x and y axes. Change either
or both of these values to move the object.

ShearRotation

Width

Lock Proportions
(width and height) 

Height

Horizontal 
Align Left

Vertical
Align Top

Vertical Distribute Center

Horizontal Align Center

Vertical 
Align Center

Horizontal Align Right

Vertical Align
Bottom

Horizontal 
Distribute Left

Vertical 
Distribute Top

Horizontal 
Distribute Right

Vertical Distribute Bottom

Horizontal 
Distribute
Center

Vertical 
Distribute Space

Horizontal Distribute Space Distribute spacing value

new



Actions palette
Actions let you automate the application of
commands and editing steps. As you create
or edit an illustration, you can record a
series of commands or steps, then save that
series as an action. You can then replay
those commands on any object, file, or
batch of files by playing the action.
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An action

A recorded
command

An actions set

Toggle command
on or off 

Toggle dialog box
pause on or off 

Stop (playing/
recording)

Begin
Recording

Play Current Selection

New
Set

New
Action

Enter the desired zoom 
percentage (3.13%–6400%),
then press Return/Enter. Or 
to zoom to a percentage and
keep the field highlighted,
press Shift-Return/Shift-Enter.

Click the Zoom Out
button to reduce the
magnification.

Move the
Zoom slider
to change the
magnification.

Click the Zoom In
button to magnify
the image.

Cmd-drag/Ctrl-
drag within the
view box to define
the view area.

Drag the view box to move the illustra-
tion in the document window, or click
the illustration thumbnail to move 
that area of the illustration into view.

Artboard

Delete
Selection

Navigator palette
The Navigator palette lets you move an illus-
tration in its window and change the onscreen
magnification (zoom level) of an illustration.



Links palette
A linked image is an image that’s placed into
an Illustrator file without being embedded into
the file. The Links palette lets you keep track
of and update linked images, modify linked
images in their original applications, and 
convert linked images to embedded images. 

Pathfinder palette Shift-F9
The shape mode buttons on the top row of
the Pathfinder palette create new, editable,
flexible compound shapes from selected
objects. The Expand button converts a com-
pound shape into either a path or a com-
pound path, depending on how the objects
originally overlapped. The pathfinder but-
tons on the bottom row of the Pathfinder
palette produce flattened, cut-up shapes from
selected objects. 
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Links Palette; Pathfinder Palette

Add to Shape Area

Subtract from Shape Area

Intersect Shape Areas
Exclude Overlapping
Shape Areas

Minus BackDivide Trim Merge Crop Outline

Relink

Modified
Linked
Image
indicator

Missing
Linked
Image
indicator

Go to
Link

Update
Link

Edit
Original

Expand compound shape
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Brushes palette F5
You can use any of the four varieties 
of brushes on the Brushes palette—
Calligraphic, Scatter, Art, or Pattern—to
apply brush strokes to paths. There are 
two methods for doing this. You can either
choose the Paintbrush tool and a brush and
then draw a shape, or you can apply a brush
stroke to an existing path that was drawn
using any tool. The brushes that are cur-
rently on the Brushes palette save with the
document. To personalize your brush
strokes, you can create your own brushes. 

To change the contour of a brush stroke, 
you can use any tool or command that you’d
normally use to reshape a path (e.g., Erase,
Reshape, Pencil, Smooth, Add Anchor Point,
or Convert Anchor Point). If you modify a
brush that’s been applied to any existing
paths in a document, you’ll be given the
option via an alert dialog box to update
those paths with the revised brush.

Transparency palette Shift-F10
You can use the Transparency palette to
change the blending mode or opacity of 
any layer, group, or individual object. Via a
Transparency palette menu command, you
can generate an opacity mask from two or
more selected objects. 
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Calligraphic
brushes

Scatter
brushes

Art
brushes

Pattern
brushes

Remove
Brush
Stroke 

Options of
Selected
Object

New
Brush

Delete
Brush
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Object Opacity

Click the opacity mask
thumbnail to select the
opacity mask for editing.

Blending mode

Object thumbnail

Isolate Blending
limits the blending 

mode effect to a group.

Knockout Group prevents
objects in a group from
showing through each other.

This option allows nested objects in 
a knockout group to show through
transparent areas of an opacity mask.



Graphic Styles palette Shift-F5
Graphic styles are sets of attributes that can
be used to quickly change an object’s appear-
ance. Among the attributes that a style can
contain are multiple solid-color or pattern
fills, multiple strokes, transparency and over-
print settings, blending modes, brush strokes,
and effects. Using graphic styles helps you
speed up and standardize object styling. 
(This was formerly called the Styles palette.)

23

ILLUSTRATOR INTERFACE
G
raphic Styles Palette; Appearance Palette

New Art
Has Basic
Appearance

Clear
Appearance

Reduce to Basic Appearance

Duplicate
Selected
Item

Delete
Selected
Item

Style thumbnails
and names

Delete
Graphic
Style

New
Graphic
Style

Break Link to
Graphic Style

Click this icon (or the effect
name) to edit the effect.

Appearance palette Shift-F6
The Appearance palette lists in minute detail
the individual attributes that are applied to
the currently targeted layer(s), group(s), or
object(s). You can use the palette to edit,
add, or remove attributes, and to edit the
attributes of a style in conjunction with the
Graphic Styles palette. You can also use this
palette to apply multiple fills and/or strokes
to a layer, group, or object, and to quickly
access the palettes and dialog boxes that
were used to apply those attributes. 



SVG Interactivity palette
You can use the SVG Interactivity palette to
add interactivity to an Illustrator object for
viewing in a Web browser. First you choose
from a list of common JavaScript events on
the Event pop-up menu. Then you add or
enter a JavaScript command that will act 
on the object when that event occurs in the
browser.

Attributes palette F11
You can use the Attributes palette to specify
overprint options for an object, show or hide
an object’s center point, reverse the fill of an
object in a compound path, or change an
object’s fill rule. You can choose a shape for
an image map area from the Image Map
menu. In the URL field, you can enter a Web
address for an object to designate it as a hot
point on an image map. Click Browser to
launch the currently installed Web browser.

Document Info palette
Like the Info palette, the Document Info
palette isn’t interactive. It’s used solely for
reading information about the current docu-
ment, or individual objects, graphic styles,
brushes—or whichever category you choose
from the palette menu.
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Show
Center 

Don’t
Show

Center 

Link JavaScript
Files

Remove Selected
Entry

Reverse Path Direction Off and Reverse Path
Direction On buttons (switch the fill between
color and transparency in a compound path)

Use Even-Odd Fill Rule

Use Non-Zero Winding Fill Rule

JavaScript Event pop-up menu



Magic Wand palette
The Magic Wand tool selects objects that
have the same or similar fill color, stroke
color, stroke weight, opacity, or blending
mode as the currently selected object. Using
the Magic Wand palette, you can choose
parameters for the tool. The Tolerance is 
the range within which the tool selects that
attribute. For example, if you check Opacity,
choose an opacity Tolerance of 10%, then
select an object that has an opacity of 50%,
the tool will find and select all objects that
have an opacity between 40% and 60%.   

Symbols palette Shift-F11
Any Illustrator object can be stored on the
Symbols palette for potential reuse in any
document. To place one symbol onto the art-
board, all you have to do is drag it out of the
Symbols palette. A placed symbol is called 
an instance. The Symbol Sprayer tool is used
to place multiple instances of a symbol in 
a document. Multiple instances form what 
is called a symbol set. Using symbols lets 
you create complex art quickly and easily. 

Using any of the other symbolism tools
(Symbol Shifter, Scruncher, Sizer, Spinner,
Stainer, Screener, or Styler), you can change
the closeness (density), position, stacking
order, size, rotation, transparency, color tint,
or style of multiple symbol instances in a
symbol set, while still maintaining the link 
to the original symbol. If you edit the origi-
nal symbol, any instances of that symbol in
the document will update automatically.

Note: For a very brief synopsis of what the
Variables palette does, see page 514. For
more information about this advanced fea-
ture, refer to the Illustrator Help file or get 
ahold of Real World Adobe Illustrator CS
by Deke McClelland (Peachpit Press).

Read about the Flattener Preview palette in
Illustrator Help.
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The Tolerance is the range within which
the Magic Wand will find that attribute.

Place Symbol
Instance

Delete
Symbol

New SymbolReplace Symbol

Break Link
to Symbol
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Path (Or “object”) Any individual shape that’s created
in Illustrator. A path can be open (a line with 
two endpoints) or closed (no endpoints). Path 
segments are joined together by smooth and/or
corner anchor points. 

Smooth anchor points have a pair of direction
lines that move in tandem and form a straight line.
Corner points can have no direction lines, one
direction line, or a pair of direction lines that can
be moved independently. 

A curve segment can join two smooth points, or 
a corner point and a smooth point. A straight 
segment always joins two corner points. You can
reshape any path by modifying its anchor points
and/or segments. 

Direction lines The pair of antennae that stick out from every
smooth point. To reshape a curved segment, you’ll
rotate, lengthen, or shorten a direction line on the
anchor point that connects the segment.  

Select To highlight an object in the document window
for editing. Only selected objects can be modified.
When a whole object is selected, its anchor points
are solid (not hollow). The Selection tool selects
whole objects or groups; the Group Selection tool
selects nested groups; the Direct Selection tool
and Lasso tool select parts of objects; and the
Magic Wand tool selects objects based on such
criteria as fill color, stroke color, stroke weight,
opacity, or blending mode.

Layer A tier of a document that holds a stack of objects.
An illustration can contain multiple top-level 
layers and sublayers. The actual objects that make
up an illustration (paths, type, mesh objects, etc.)
are nested within top-level layers or sublayers.  

Group Two or more objects that are united via the Group
command so they can be moved or modified in
unison.

Transform To rotate, scale, reflect, or shear an object, or 
create a blend between two objects.

Objects

Closed
path

Anchor
point

Curve
segment

Straight
segment

Selected
object

Selected anchor point

Direction line

Open
path

Mini-Glossary A brief introduction to some of
the terms that you’ll encounter as you read this book.

Object undergoing a
scale transformation
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Fill The color, pattern, or gradient that’s applied to the
inside of an object.  

Stroke The solid color that’s applied to the edge of an object.

Blend A multistep color and shape progression between two
or more objects. If you reshape, recolor, or move any
of the individual objects in a blend or reshape, move,
or transform the path that controls the whole blend,
the blend updates automatically.

Brush stroke A Calligraphic, Art, Scatter, or Pattern embellishment
that’s either applied to an existing path or drawn
using the Paintbrush tool.  

Gradient A gradual blending of two or more colors within 
an object. A gradient fill can be linear (side to side) 
or radial (radiating outward from a center point).   

Mesh An editable object fill, composed of multicolored 
gradients along mesh lines, that’s created by using
either the Mesh tool or the Create Gradient Mesh
command.   

Compound shape An editable (and reversible) union of overlapping
objects produced via the Shape Mode buttons on 
the Pathfinder palette. If individual objects within a 
compound shape are moved, restacked, or reshaped,
the overall compound shape readjusts accordingly. 

Compound path Two or more objects combined into one object—
that is, until or unless the compound path is released.
Where the original objects overlapped, a transparent
hole is created, through which shapes or patterns
behind the object are revealed. 

Pathfinders Commands on the Pathfinder palette that determine
where selected paths overlap and then divide, trim,
merge, crop, outline, or subtract from them to 
produce nonoverlapping (flattened) closed paths.
These commands aren’t reversible, except by using
Undo. 

Clipping mask A command that uses an object to trim (clip) away
parts of other objects that extend beyond its border.
The clipped areas don’t display or print. An opacity
mask applies a mask based on opacity values.

Fill

Compound path made
from the circle and star

Original
objects

Compound shape made
from the three objects

Original
objects

Radial
gradient

Blend created using a
circle and a star

Art 
brush stroke

Stroke

Mesh

(Continued on the following page)



Appearances Editable and removable attributes, such as 
multiple fills, strokes, effects, blending modes,
transparency values, patterns, and brush strokes.

Style A set of graphic appearance attributes that’s saved
to, and applied via, the Graphic Styles palette; 
a set of character attributes that’s created and
applied via the Character Styles palette; or a set
of paragraph and character attributes that’s cre-
ated and applied via the Paragraph Styles palette.

Effects Commands on the Effect menu that modify 
the appearance of an object without actually
changing its path shape. Effects can be edited or
removed at any time via the Appearance palette.

Symbol Reusable objects that are stored on the Symbols
palette and can be placed into any document. 
A placed symbol is called an instance; multiple
instances form symbol sets. Instances can be
modified by using the symbolism tools.

Liquify Seven tools—Warp, Twirl, Pucker, Bloat,
Scallop, Crystallize, and Wrinkle—that are used
to reshape an object or objects. By pushing and
pulling on an object’s edges with one of these
tools,  you can reshape the object as you might
sculpt a piece of clay. Many of the Effect com-
mands also produce distortion.

Envelope A special kind of container that’s used for apply-
ing distortion. When you distort an envelope,
everything within the envelope conforms to the
distortion. Both an envelope and the object(s) it
contains are fully editable. 

Action A recorded sequence of editing events that can
be replayed on any object, file, or batch of files. 

Optimization The process in which file format, storage size,
and color parameters are chosen for an image 
in order to maximize its quality yet enable it 
to download and display quickly on the Web.  

Slicing The division of areas in an illustration. When
exporting an illustration using Illustrator’s Save
for Web dialog box, you can choose different
optimization formats and settings for each slice 
in order to achieve faster download speeds. A
separate export file is generated for each slice
and the object or objects that it contains. Three
types of slices can be created in Illustrator: object
slices, text slices, and user slices.
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Envelope
distortion

Drop shadow effect

Symbol set

Illustration divided into slices

Symbol
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Measuring up
The measurement unit that you choose for
an individual document (instructions below)
overrides the measurement unit that’s chosen
for the application in Illustrator (Edit, in
Windows) > Preferences > Units & Display
Performance. The current unit is used as the
default value in entry fields in most palettes
and dialog boxes, and on the rulers.

You can enter values in dialog boxes and
palettes in any of the measurement units
listed in the sidebar at left, regardless of the
current default units. If you enter a value 
in a nondefault unit, it will be translated 
into the default unit when you press Tab or
Return/Enter. 

➤ If you enter the symbol for subtraction (-),
addition (+), multiplication (*), division (/),
or percent (%) after the current value in
any field, Illustrator will do the math for
you (see the sidebar).

➤ To enter a combination of picas and
points, separate the two numbers by 
a “p”. For example, 4p2 equals 4 picas
plus 2 points, or 50 pt. Be sure to high-
light the entire entry field first.

Follow the instructions below to change 
the measurement units just for the current
document. To choose a measurement unit 
for the current and future documents, go to
Illustrator (Edit, in Windows) > Preferences >
Units & Display Performance.

To change the units for the current
document:
If the rulers aren’t showing, choose View >
Show Rulers (Cmd-R/Ctrl-R), then Control-
click/right-click either ruler and choose a
unit from the context menu �.
or
Choose File > Document Setup (Cmd-
Option-P/Ctrl-Alt-P); choose Artboard from
the pop-up menu; choose Units: Points,
Picas, Inches, Millimeters, Centimeters, or
Pixels �; then click OK. 

➤ The current location of the pointer is
indicated by a dotted line on both rulers.
The higher the zoom level, the finer the
ruler increments.  
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Division the easy way

Let’s say you want to reduce an object’s width
by 25%. Select the object, highlight the entire W
field on the Transform palette, type “75%”, then
press Return/Enter. The width will be reduced
to three-quarters of its current value (e.g., 4p
becomes 3p). You could also click to the right
of the current entry, type an asterisk (*), type 
a percentage value, then press Return/Enter.

� ...or from the Units pop-up menu in the
Document Setup dialog box.

� You can choose Units via a context menu in the
document window...
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U
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Symbols you can use

Unit Symbol

Picas p
Points pt
Inches " or in

Millimeters mm
Centimeters cm

Q (a type unit) q
Pixels px

Points ’n’ picas

12 pt = 1 pica

6 picas = 1 inch
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Multiple undos
To undo an operation, choose Edit > Undo
(Cmd-Z/Ctrl-Z). To undo the second-to-last
operation, choose Edit > Undo again, and so
on. To reverse an undo, choose Edit > Redo
(Cmd-Shift-Z/Ctrl-Shift-Z). You can also
Control-click/right-click on the artboard and
choose either command from the context
menu. You can undo or redo after saving
your document, but not after you close and
reopen it. 

Contextual menus
Contextual menus allow you to choose a
command from an onscreen menu without
having to mouse to the menu bar or even to
a palette. To open a contextual menu (or
“context menu,” for short), Control-click/
right-click on the artboard. 

Context menu offerings change depending 
on which tool is selected and whether any
objects are selected in your illustration �–�.
Not all of the commands that appear on 
a context menu may be applicable to, or
available for, the currently selected objects.

And don’t forget

Use tool tips to help you identify palette but-
tons, swatch names, tool names, tool shortcuts,
and other application features. Simply rest the
pointer without clicking on a button, swatch, or
icon, and a tip will pop up onscreen �.
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� Context menu when nothing is selected

� Context menu
when two paths are
selected

� Context menu when type
is selected

� A tool tip


