
The major limitation associated with using page transitions is that they are controlled by the pref-

erences on each user’s machine. Fortunately, there are several ways to embed the instructions for

page transitions within the document. This makes it possible to create sophisticated page transi-

tions that play anywhere, without relying on the user’s preference settings.

Embedding Page Transitions10.3

DYNAMIC PRESENTATIONS

ACROBAT PDFMARKS

Back in the days of Acrobat 3, the Acrobat 

contained a folder of transition  files. You

imported an  into the page layout. When

the document was distilled, the transition was

embedded as part of the page. These transitions

overruled the preference settings and allowed

different transitions for each page. If you have

access to an Acrobat 3 , you can still use

those files.

EMBEDDING PAGE TRANSITIONS
FROM THE JAVASCRIPT CONSOLE 

These days there are easier ways to embed page

transitions. The JavaScript Console lets you

type in commands (calls) that control page

transitions. Using the JavaScript

console, you can set different

transitions for the various pages.

You can also set the length of

time each transition runs. More

importantly, these transitions

work in the normal and full

screen modes. This method of embedding

transitions also works when the document is

viewed in Reader 4.

Is this easy? We asked the most code-phobic

member of our team (Sandee) to try it. Here

are the steps she took to add the Box In tran-

sition for the first two pages of a document.

Don’t try to understand the code, right now;

we’ll explain it all after you’ve followed the

steps and seen it work.

Step Open the JavaScript Console

Choose Tools>JavaScript>Console. The Java-

Script Console dialog box appears. Don’t worry

about any text that may be in the console area.

The main concern should be the new text 

you enter.

Step Type the JavaScript

Click inside the white area of the console, and

make sure you’re on a new line. Enter the fol-

lowing code as one line, exactly as written.

(Watch for the spaces after the colons and

commas.)

this.setPageTransitions({nStart: 0,

aTrans: [-1, "BoxIn", 1], nEnd: 1});

Press the enter key on the numeric key pad to

send the code from the console into the docu-

ment. If you’ve entered the text correctly, you

will see the word “undefined” appear in the

console text area. If you’re on a keyboard that

doesn’t have a numeric keypad, hold the Alt

key () or Control key () when you press

Enter (Return) to execute the script.

Step Save and Test

Save the file, close the document, and then

reopen it. Use any of the navigation controls

to move between pages. The first two pages

The JavaScript from this sec-
tion is included on the Acrobat
Master Class cd. You can
copy and paste it from our
text file into the JavaScript
Console. 

ON THE CD

Adobe Acrobat 5 Master Class
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PDFMARK 
If you still have your
CD from Acrobat 3,
look for the Trans
(W) or Transitions
(M) folder in the
Utility folder. Place
the EPS files onto
the page in the
authoring applica-
tion. Then distill the

JAVASCRIPT 
CONSOLE 
This is quite an easy
method, even if you
are not familiar with
JavaScript. Go to
Tools>JavaScript>
Console and type
the script into the
console. Hit Enter
on your numeric
keypad and the
word “undefined”

THIRD PARTY
PLUG-INS
These products pro-
vide an interface for
setting page transi-
tions. They can all be
purchased from the
Planet PDF ePublish
store at www.epub-
lishstore.com.

file. The transitions
are embedded in the
file. This is how the
code looks in a text
editor, such as
BBEdit. 

will appear. You can
test your results by
moving from page
to page. You must
save the document
for the transitions to
be permanent. 

Actino Software’s Pre-
sentation Tool (W),
$75, lets you set the
duration and page
advance, in addition
to the transition.

Kas Thomas’ Transi-
tionAny (W) $50, does
page transitions only.

ARTS PDF Tools (W/M)
$149, does page tran-
sitions and a whole
lot more.
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will appear with the Box In transition. The

other pages will appear with whatever transi-

tion has been set in the Full Screen Prefer-

ences. If you want to modify your embedded

page transition, you must enter the new call

in the console and then press the Enter key to

send it to the document.

UNDERSTANDING THE JAVASCRIPT
PAGE TRANSITIONS CODE

Here’s a breakdown of the JavaScript code in

the previous exercise.

this.setPageTransitions({nStart: 0,

aTrans: [-1, "BoxIn", 1], nEnd: 1});

This phrase says the script is to set the page

transitions.

this.setPageTransitions({nStart: 0,

aTrans: [-1, "BoxIn", 1], nEnd: 1});

nStart specifies the page of the document for

the transition. Acrobat starts numbering

pages with 0.

this.setPageTransitions({nStart: 0,

aTrans: [-1, "BoxIn", 1], nEnd: 1});

aTrans sets the definition array for the transi-

tion.

this.setPageTransitions({nStart: 0,

aTrans: [-1, "BoxIn", 1], nEnd: 1});

The information in the square brackets is an

array, and sets the definition of the transition.

The first number controls how long (in sec-

onds) the page is displayed. The value of -

turns off automatic page advancing.

this.setPageTransitions({nStart: 0,

aTrans: [-1, "BoxIn", 1], nEnd: 1});

This is the name of the transition as it appears

in the preferences. Type the name of all tran-

sitions without any spaces.

this.setPageTransitions({nStart: 0,

aTrans: [-1, "BoxIn", 1], nEnd: 1});

This number sets the duration of the transition.

The 1 here stands for one second.

this.setPageTransitions({nStart: 0,

aTrans: [-1, "BoxIn", 1], nEnd: 1});

The nEnd number stands for the last page you

want the transition applied to. If you want only

one page to have the transition, you can delete

this part of the code.

Applying a Transition to All the Pages

If you want to apply a transition to all the

pages in a document, use this code. (Here, we

changed the transition to Dissolve.)

this.setPageTransitions({aTrans: 

[-1, "Dissolve", 1]});

Deleting the Embedded Code

What if you want to get back to a normal doc-

ument without embedded transitions? You’ll

have to send a command to delete the embed-

ded transitions. (Clearing the JavaScript Con-

sole won’t work.) Here’s the code to delete the

transitions from the first two pages.

this.setPageTransitions({nStart: 0,

nEnd: 1});

Choose Tools>
JavaScript>Console.
The JavaScript Con-
sole dialog box will
appear.

Save the document
and test the transi-
tion in the Full
Screen mode.

Type the text for the
code and then press
the Enter key on the
keypad. The word
“undefined” appears.

Adobe Acrobat 5 Master Class
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PLUG IN

Pattie Belle calls arts
pdf Tools her Acrobat
time management sys-
tem. It’s actually a cus-
tomizable tool bar that
comes with more than
70 pre-defined tools and
advanced Acrobat com-
mands. You can also
make and edit your
own tools.

Imagine, if you will,
having a button on your
tool bar that instantly
applies all your favorite
Open Document
options! The Set Open
Options button allows
you to define any or all
of your favorite Docu-

ment Open Options:
Open with the page only,
with bookmarks or
thumbnails; page num-
ber, magnification and
layout; open in normal
or full screen mode;
and hide or display the
menu, tool bar or win-
dow controls.

You can add any of
the pre-defined tools by
selecting them and
importing them onto
the tool bar. You can
also make new tools by
selecting your own com-
mands and menu items,
and then assigning a tool
bar button to them. You

can copy and share your
custom tools with other
users by using the
Import/Export feature.
You can even create a
new blank pdf from
within Acrobat.

Although arts pdf
Tools is available for
both Mac and Win-
dows, it’s the first prod-
uct that provides a user
interface to customize
and embed page transi-
tions on the Macintosh.
It comes with three
tools for page transi-
tions: Apply Transition
to Current Page, Apply
Transition to All Pages,

and Display Current
Page Transition.

arts pdf Tools also
gives you access to
advanced tool creation
with JavaScript. Many
of the plug-in’s built-in
tools contain JavaScript
that is completely open
to modification. This
means it can be used in
the creation of other
custom tools.

The demo version
allows you to use five
tools before you have to
restart Acrobat. arts
pdf Tools is available
for $149 at www.epub-
lishstore.com.

Some of the arts pdf Tools
as they appear on the Acro-
bat tool bar.

Want those instant Docu-
ment Open Options? Click
on the Wrench to open the
tool box, select the Open
Options tool from the list
and click Edit. The dialog
box lets you select all your

Click the Apply Transition To
Current Page button to pick
from the list of Acrobat’s
built-in page transitions.
These can be applied to indi-
vidual pages, as well as the
entire document.

arts pdf Tools

favorite settings. From that
point on, all you have to do is
click the Open Options but-
ton on the tool bar and the
options will be instantly set.
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Glenn Page calls himself a corporate consult-

ant, but that hardly does justice to his talents

as a designer, copywriter, salesman, voice-over

announcer, and -magician.

FROM PRINT TO 
INTERACTIVE MARKETING

Glenn is the principle director of gpmCommu-

nications, a corporate sales and marketing firm.

Several years back, Glenn felt he had reached

a creative dead-end with print documents and

decided to make the move to digital marketing.

He had been working in QuarkXPress and

InDesign and was looking at the possibilities

of multimedia and interactive presentations

using Macromedia Director. Then

one of his client requested a 

proof of a project.

While researching the fea-

tures of Acrobat, Glenn came

across information on interactive

 files in Ted Padova’s 

Bible. His interest was piqued. Unlike Director,

Acrobat and  allowed him to use his famil-

iar print software and still create animated,

interactive projects. He also had much better

control of text. Acrobat was the multimedia

application he had been looking for.

Glenn’s first project was an interactive

portfolio for himself. He was immediately

impressed with Acrobat’s ability to transform

print-based documents into multimedia expe-

riences. He also realized that interactive, 

brochures (Glenn calls them iBrochures) are

much more than ordinary slide presentations.

They give the viewer a range of options for

navigating through the document. The more

time a viewer spends playing with one of

Glenn’s iBrochures, the more likely they are to

call or e-mail for more information.

BEHIND THE SCENES AT GPMC

Glenn uses his own small studio with profes-

sional audio equipment and software. This is

very important, as he makes ample use of

sounds and voice-over narration.

His Acrobat files start in InDesign with a

page size of approximately  inches. This

allows them to fit neatly into most computer

screens, with just a little background color.

The iBrochure presentations are designed

to be downloaded from a company’s website

or sent as an e-mail attachment. The animation

for the iBrochures comes not from movie

objects, but through the clever use of page

transitions. This helps keep the size of the

iBrochure to a minimum.

For the page transitions, Glenn used bbe-

dit to open the  files from the Acrobat 3

. He then changed the timing of the transi-

When we first saw Glenn Page’s pdf presentations we were blown away! They were unique—

they looked more like Flash movies than Acrobat files. When we found out how he created them,

we were even more amazed. The first thing you’ll notice when you view his documents is that

they seem to be self-running presentations. Then, they stop and let the user interact with the ele-

ments. Certainly, that can’t be possible—but there it is. Here’s a little background on Maestro

Page, and some of the secrets behind the curtain.

Transition Magic10.4

DYNAMIC PRESENTATIONS

Samples of Glenn Page’s pdf
presentations can be found on
the Acrobat Master Class cd.
You can find more informa-
tion about Glenn’s work at 
www.gpmconnect.com. 

ON THE CD

Adobe Acrobat 5 Master Class

326



GPMC iBrochures are
designed with all the
care of print docu-
ments. This type of
control is not possible
with other presenta-
tion applications.
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tions—faster or slower —to suit his needs. The

timing of these transitions is actually the most

critical aspect. The transitions can’t be too long

or too short. Glenn spends a lot of time testing

the transitions.

He then imports these  files onto their

own layer on the appropriate pages in InDesign.

He can also put one transition on a master page

to apply it to all the pages in the document. He

then converted the InDesign documents to a

 document using Distiller. Although InDe-

sign has an Export as  feature, that feature

does not recognize the  transition files.

CREATING A CUSTOM 
AUTO-RUN PRESENTATION

Glenn uses the  page transition files from

the Acrobat  . However, you can achieve

the same effect by embedding page transitions

using the JavaScript Console. The following

steps show how to use page transitions and

page actions to create a custom

self-running presentation. The

benefit of using the embedded

transitions is that they override

any transitions set on the user’s

machine.

The presentation opens in

the Full Screen mode. When the

document opens, the first five

pages are automatically displayed with custom

transitions that wipe from left to right. The

visuals create a countdown effect:    

. On the fifth page, the presentation stops. A

button lets the viewer move to the next page.

On the last page, the viewer clicks a button

which exits the full screen mode.

Step Set the Page Transitions

Our first step adds the code to the JavaScript

Console. Choose Tools>JavaScript>Console.

Click in the Console field and enter the follow-

ing code.

this.setPageTransitions({aTrans: 

[-1, "WipeRight", 1]});

This code set applies the Wipe Right transition

to all the pages with a one-second transition

time. We set the timing for all the pages so we

could control the appearance for the entire

document.

Don’t set the timing too fast. At first we

tried a tenth of a second and found that Acro-

bat couldn’t combine the page transition with

the page actions at that speed. The presentation

just jumped to page five without any transitions

at all.

Don’t forget to save your work. The code

isn’t embedded in the document until it is

saved.

Step Set the Page Actions

Now you’ll need to set the page actions for the

first four pages. This moves the presentation

automatically through the numbers , , ,

FOLLOW ALONG

Look on the cd for before
and after versions of the
Autorun document featured
in these steps. You can open
the after version to see the
finished effect. Then open
the before version to follow
along with the steps.

Choose Tools>Java-
Script>Console. The
JavaScript Console dia-
log box will appear.
Type the code in the
Console and press the
Enter key.

Move to the first page
and choose Docu-
ment>Set Page
Action. Choose Page
Open and click the
Add button. For

Action Type, choose
Execute Menu Item
and then choose Doc-
ument>Next Page.
Repeat for pages two,
three, and four. 

Adobe Acrobat 5 Master Class
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and . It then stops on the page that contains

the number .

Move to the first page (numbered ) and

choose Document>Set Page Action. Click the

Page Open event and click the Add button. In

the Add an Action dialog box, set the Action

Type to Execute Menu Item. Then click the Edit

Menu Item button. Choose the Document>

Next Page menu command. Click  and Set

Action to close the Add an Action dialog box.

Move to the next page (numbered ) and

repeat this step. Then move to the next page

and repeat the step. Continue until you get to

the fifth page, (numbered ). Then stop. Don’t

apply a page action to that page. That’s where

we want the presentation to pause for the

viewer’s input.

When you set Page Actions to advance from

one page to another, you may find it difficult to

go back and edit the pages. As soon as you go

to the page, the Page Action takes you to the

next page. Set the View to Continuous-Facing.

This stops the Page Actions, so you can edit

pages. You may have to increase the magnifi-

cation so the odd-numbered pages touch the

left-side of the document window. That’s how

Acrobat recognizes that you’re working on a

specific page.

Step Create the Buttons

At this point, we want the presentation to stop

moving from page to page, in order to allow

the viewer to control page navigation. To do

this, you’ll need to add a custom navigation

button. (Glenn Page’s presentations are much

more complex than this simplistic example,

but the principle is the same.)

On page five, (numbered ), use the Form

tool to draw a button. Name the button, and

set the action to Execute the menu item to go

to Document>Next Page.

On the last page, (labeled ), use the Form

tool to draw a button. Name the button and set

the action to execute the menu item View>Full

Screen. If the document is in Full Screen, the

command exits the mode.

Step Set the Open Options

As a last step, choose File>Document Proper-

ties>Open Options. Set the Window Options

to Open in Full Screen. Set the Magnification to

the size that is appropriate for your document.

We chose Fit in Window. We also chose the

Page Layout as Single Page. This forces us to

remember to reset the document from Con-

tinuous-Facing to Single Page.

Save your work and close the document.

Reopen the file and test all the transitions 

and buttons.

On page five, use the
Form tool to create a
button with the Doc-
ument>Next Page
command.

On the last page, use
the Form tool to cre-
ate a button with the
View>Full Screen
command.

Choose File>Document
Properties>Open
Options. Set the Win-
dow Options to Open

in Full Screen. Set the
Magnification as
desired. Set the Page
Layout to Single Page.
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