
Adjusting Content Sp a c i n g
In addition to table spacing, you can adjust
where the content in your table’s cells is
placed:

◆ In both horizontal and vertical al ign ment ,
choosing Default sets the alignment to
the browser’s default—usually left (hori-
zontal) and middle (vertical).

◆ In most cases, then, you won’t need to set
alignment specifications for left or mid-
dle unless you’re “changing it back” from
a previous adjustment.

◆ Cell alignment properties override row
and column specs, and column specs
override row specs.

Changing Content alignment

Horizontal al ign ment within a cell is the same
as regular alignment on a page: the text is
al igned with the left, right, or center of the cell .
Vertical alignment controls the position of
the text between the top and bottom of a cell .

To change content alignment:

1. Click to place the insertion point in the
column, row, or cell whose horizontal
alignment you want to adjust. The
Properties inspector will display proper-
ties for your selection. Verify that you
selected the correct area by checking the
Apply button on the Properties inspector.

2. Click on the Horz drop-down menu, and
select an alignment option: Default, Left,
Center, or Right (Figure 10.56).

3. Click on the Vert drop-down menu and
select an option: Default, Top, Middle,
Bottom, or Baseline (Figure 10.57).

4. Click on OK to close the dialog box.

Your changes will be apparent when you
place content in that area of the table
(Figure 10.58).
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Figure 10.56 Horizontal alignment (Horz) options
include Default, Left, Center, and Right.

Figure 10.57 Vertical alignment
options (Vert) include Default,
Top, Middle, Bottom, and
Baseline.

Figure 10.58 This table runs the gamut of content
alignment options. The position of the Baseline
vertical alignment is based on the imaginary lines
that the characters rest on, and it generally follows
the baseline of the bordering cells.



Coloring Tables
You can give a table a background color or
backgrou nd image that differs from the back-
ground of the overall page. You can also use
d ifferent backgrou nds in ind ividual table cell s .

To choose a table background color:

1. Select the table and the Properties
inspector will display Table properties.

2. If the Table Properties inspector is col-
lapsed, expand it by clicking on the
Expander arrow.

3. In the Bg Color text box:
◆ Type or paste a hex value for the back-

ground color.

or

Click on the gray Color selector button
to pop up the Colors palette (Figure
10.59). Hold down the mouse button
and drag the pointer to select a color
(Figure 10.60).

or

On the Colors palette, click on the
Colors button to open up the Color
dialog box (Figure 10.61). For more
on using the Color dialog box, see
Chapter 2.

When you’re finished making your selection,
click on your color choice, and click on OK to
close the Color dialog box, if necessary. The
color change shou ld be apparent immed i ately.

✔ Tips

■ You can follow these steps for a single
cell, a selection of cells, a column
(Figure 10.62), or a row or entire table.

■ To escape without choosing a color, press
the Esc key (Windows only), or click on
the space below the Colors palette. More
color shortcuts are discussed in Chapter 2.
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Figure 10.59 Click on the Color Selector button to pop
up the Colors palette.

Figure 10.60 Choose a color from the Colors palette by
clicking on it.

Figure 10.61 The Color dialog box offers additional
color selection options. The Color dialog box for the
Macintosh is substantively different, as discussed in
Chapter 2.

Figure 10.62 I colored one column in this
table. Notice that the table, the page,
and the column use three different
colors.



Adjusting border colors

There are three possible border color selec-
tions you can make: Border, Light Border,
and Dark Border.

To adjust border colors:

1. Select your table to view table properties
in the Properties inspector.

2. For one (or all) of the color choices,
Border, Light Border, and Dark Border,
follow step 3 in To choose a table back-
ground color on the previous page.

Figure 10.63 shows a table with colored
borders, and Figure 10.64 shows a table
with light and dark border colors.

✔ Tips

■ You can adjust the color of the border, the
light border, or the dark border for a row,
a column, or a single cell as well. 

■ Netscape shows border colors as shades
of the selected colors. A lighter tint
appears on the upper and left borders of
the table, and a darker shade appears on
the lower and right borders of the table. 

■ Internet Explorer shows border colors as
a solid outline around each cell in the
table, unless light and dark border colors
are selected, in which case the regular
border color is not shown at all.

■ Navigator will display the Border color,
but not the Light and Dark Border colors.
Those are conventions of Internet
Explorer.

■ You can set the Border, Light Border, and
the Dark Border, but all three of them will
not show up at once. However, this is the
only way to get shaded borders in both
Navigator and IE.
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Figure 10.63 This table, seen in Navigator 4.5 on top
and IE 5 below, has colored borders. In Navigator, the
color appears only on the table’s outer edges.

Figure 10.64 I used yellow for the light border color
and dark gray for the dark border colors. Navigator
doesn’t display light or dark border colors, and IE
displays both.



Setting a background image

You can set a background image for an entire
table, a table cell, a column, or a row.

To use a table background image:

1. In the Document window, select the table
or table element you want to supply with
a background image. 

2. In the Properties inspector, type the URL
of the image you want to use in the Bg
text box (the larger of the two identically
named text boxes) (Figure 10.65). 

or

Click on the Browse button to open the
Select Image Source dialog box and select
the image from your local machine.

or

If you’re using a local Site, drag the Point
to File icon onto the image file in the
Sites window.

Either way, the image path will appear in
the Bg text box, and the image will load in
the table in the Document window

Figure 10.66 shows a table that uses a back-
ground image.

✔ Tip

■ A convenient shortcut for coloring tables
is the Format Table dialog box (Figure
10.67), which allows you to choose from
predetermined background color
schemes. To use the dialog box, select
Commands > Format Table from the
Document window menu bar.
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Figure 10.65 Type the pathname of the background
image in the Bg text box on the Properties inspector,
or click on the Browse or Point to File buttons to use
those options.

Figure 10.66 I used a table background image in this
table. Navigator (top) tiles the image in each cell,
while IE (bottom) uses the image as a background for
the entire table.

Figure 10.67 Use the Format Table dialog box to
choose from predetermined color schemes. Any color
choices you make for columns or individual cells will
override these default schemes.

Point to file           Browse



Inserting Tabular Data
Using Dreamweaver 3, you can import com-
plex sets of data from database or spreadsheet
files into an HTML table. Theoretically, any
program that can save content as a delimited
data file (particularly comma- and tab-
del i mited) can be imported. Specific examples
are Microsoft Excel, Microsoft Access, 4D,
Emacs, and Oracle (Figure 10.68). 

Before beginning, you (or your database
expert) need to export the information from
the database or spreadsheet program into a
data file. You must know what character the
file uses as a delimiter. If you don’t know, get
it from your database engineer.

✔ Tip

■ Nearly any database, spreadsheet, or even
address book program can save data as
comma-delimited or tab-delimited data
files. Two notable exceptions are Lotus
Notes and Filemaker. You may need to
save out data and format it in another
application to use data from these appli-
cations in a Dreamweaver table.

To import table data:

1. You can use either of two menu com-
mands that work exactly the same. From
the Document window menu bar, select
Insert > Tabular Data.

or

From the Document window menu bar,
select File > Import > Import Table Data.

Either way, the Insert Tabular Data (or
Import Table Data) dialog box will appear
(Figure 10.69). The dialog boxes are
identical aside from their names.

2. To select the data file containing the data
to be inserted into your table, click
Browse. The Open dialog box will appear
(Figure 10.70).

continues on next page
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Figure 10.68 I want to put this Excel production
worksheet on the corporate intranet. I convert it to
HTML so that anyone in the office can access it
without needing Excel in order to open it. Before I can
import this file into Dreamweaver, I will need to save
it as a CSV file. 

Figure 10.69 The Insert Tabular Data (or Import Table
Data) dialog box allows you to choose a database or
spreadsheet file to import as an HTML table, and to
set parameters for how that table will look.

Figure 10.70 In choosing the file to import, note that I
chose the CSV file (comma-separated values, in
Microsoft terms) rather than the XLS (Excel
Spreadsheet file) just below it. 



3. Select the file and click on Open. You
will return to the Insert Tabular Data
(or Import Table Data) dialog box
(Figure 10.71).

4. Your data file uses punctuation to mark
the spaces between table cells. Usually, the
file is comma-delimited or tab-delimited;
it may also use semicolons or colons.
Choose the proper mark from the
Delimiter drop-down menu.

or

If the file uses another delimiter, select
Other, and then type the name of the
delimiter in the text box that appears.

5. You and Dreamweaver will allocate the
width of the table in the Table Width area
of the dialog box (Figure 10.71).

To base the table width on whatever
space the data takes up, click the Fit to
Data radio button. (You can reformat the
table later.)

or

To set the width, at 100 percent, for
example, type an amount in the Set text
box, and then choose Pixels or Percent
from the Set drop-down menu.

6. To preset Cell Padding and Cell Spacing,
type a number in those text boxes. (See
the previous section, Adjusting Table
Spacing, to find out how this works.)

7. Presumably, the top row will consist of
column headings; Mailing Address, for
example. To format the top row, select
Bold, Italic, or Bold Italic from the Format
Top Row drop - down menu (Figu re 10.71) .

8. To set a border (1, 0, or other), type a
number in the Border text box.

9. When you’re done, click on OK, and
Dreamweaver will import the data and
create the table in the Document window
(Figure 10.72).
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Figure 10.71 I have selected a file to import (the path
is shown in the Data File text box); I have selected
Comma as the delimiter; I have set the width of the
table to 100 Percent of the page; and I have chosen
Bold as the top-row formatting. 

Figure 10.72 After importing the file, Dreamweaver
drew this (rather plain) table. I will need to make
some changes to make it look better. Also, any
columns or fields that were hidden in the Excel file are
still imported into the Dreamweaver table. 

Format Top Row drop-down menu



Exporting Tables
You can also export table data from
Dreamweaver into a data file. For instance,
if you import data into Dreamweaver and
then update the information in Dreamweaver,
you may want to open the updated data in
your database or spreadsheet program. 

Before you begin, you need to have a page
containing a table with data in it open in
Dreamweaver.

To export table data:

1. From the Document window menu bar,
select File > Export > Export Table. The
Export Table dialog box will appear
(Figure 10.73).

2. From the Delimiter drop-down menu,
select the delimiter you wish to use. This
should be the default delimiter of the
program you’ll be importing the data
into. If you’re not sure, Comma and Tab
are safe bets.

3. In data files, line breaks are actually char-
acters. From the Line Breaks drop-down
menu, select the platform your data file
will be opened on. If you’re not sure,
check with your database guru; if you
have to guess, pick Windows.

4. Click on Export and the Export Table As
dialog box will appear. You will need to
supply a file extension with your filename .
If you’re not sure what extension to use,
you can add it later by changing the name
of the file. 

5. Click on Save. The Export Table As dialog
box will close and the file will be saved on
your computer.
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Figure 10.73 You can use the Export Table dialog box
to save an HTML table as a data file.

Figure 10.74 I applied Dreamweaver’s autoformatting
(Commands > Format Table). I also shortened the
URLs to site-root relative paths to make the table
easier to navigate, and applied some font formatting
to the header cell. 



Sorting Table Contents
Typing stuff into a table can be a pain in the
butt if you need the contents to be in order.
In Microsoft Word and Microsoft Excel, you
can type the stuff in any order you like and
then sort table contents alphabetically or
numerically. In Dreamweaver, you can do the
same thing. No, really!

To sort table contents:

1. Click within the table you want to sort.

2. From the Document window menu bar,
select Commands > Sort Table.
The Sort Table dialog box will appear
(Figure 10.75).

3. From the Sort By drop-down menu, select
the column (by number) to sort by first.

4. From the Order drop-down menu, select
Alphabetically or Numerically.

5. From the next drop-down menu, select
Ascending (A-Z, 1-9) or Descending
(Z-A, 9-1).

6. To sort by a secondary column next,
repeat steps 3-5 for the Then By section
of the dialog box.

7. To include the first row in your sort, check
the Sort Includes First Row checkbox. 

8. To have any row formatting travel with
the sort, check the Keep TR Attributes
With Sorted Row checkbox.

9. Click on OK to close the Sort Table dialog
box. The table will be sorted according to
the criteria you specified.
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Figure 10.75 Use the Sort Table dialog box to specify
criteria by which to sort the contents of a table.


