
Inside Dreamweaver MX
073571181X

Laura Gutman, Patricia J. Ayers, and Donald S. Booth

Copyright 2003 by New Riders Publishing

Warning and Disclaimer: Every effort has been made to make this book as complete and accurate
as possible, but no warranty or fitness is implied. The information is provided on an as-is basis. The

authors and New Riders Publishing shall have neither liability nor responsibility to any person or
entity with respect to any loss or damages arising from the information contained in this book or from

the use of the discs or programs that may accompany it.

Misprint Correction
Page 8
You can now have the Site panel grouped with all
your other panels!

Windows users can now have the Site panel
grouped with all your other panels!

Page 11
In previous version, it would show up in
Dreamweaver as Custom JavaScript in the
Behaviors panel. Dreamweaver will now
recognize it as a pop-up menu in the Behaviors
panel.

In previous version, the code for these menus
would show up in Dreamweaver as Custom
JavaScript in the Behaviors panel. Dreamweaver
will now recognize the code as a Show Pop-Up
Menus behavior.

Page 13
Selecting a tag from the tree view displays a Tag
Inspector in the bottom half of the panel, listing
all the attributes for the tag and its values.

Selecting a tag from the tree view displays a
property sheet in the bottom half of the panel,
listing all the attributes for the tag and its values.

Page 32
Missing sentence at the end of final paragraph.

All panels are available under the Windows
menu.

Page 34-Note
Missing final sentence.

The Sitespring panel allows users to access
Sitespring functionality.

Page 41
The display for this setup would look like this:
27K/1 sec.

The display for this setup would look like this:
28K/1 sec.

Page 57-First Note
Just enable the Show Site panel Only on Startup
option, and those automatically created new
documents are a thing of the past.

Just enable the Show Only Site Window on
Startup option, and those automatically created
new documents are a thing of the past.

Page 59
All references to “color palette” should be “color
picker.”
Page 78
Although by default Dreamweaver can edit any
HTML page, available extension can help you
with the conversion process.

Although by default Dreamweaver can edit any
HTML page, available third-party extension can
help you with the conversion process.

Page 79-First Note
Extensions are additions to Dreamweaver that
are written by developers to enhance and extend
the inherent functionality of the program.

Third-party extensions are additions to
Dreamweaver that are written by developers to
enhance and extend the inherent functionality of
the program.

Page 160
<a href=http://www.macromedia.com
target=”_new”>Click here!</a>

<a href=http://www.macromedia.com
target=”_blank”>Click here!</a>



Page 190
Figure 6.25 replacement.

Page 203-Table 7.1
(See Chapter 11, “Working with Forms.)

(See Chapter 16, “Getting Interactive with
Behaviors.)

Page 214
<meta name=”robots” content=“index,
nofollow

<meta name=”robots” content=“index,
nofollow”>

Page 225
Don’t forget the final slash (/)

This should be the beginning of another bullet
point.

Page 237
Designing the frames is covered in detail in
Chapter 11, “Working with Frames.”

Designing the frames is covered in detail in
Chapter 12, “Designing Frame-Based Pages.”

Page 265
To merge two or more table cells, select the cells
and either click the Split icon in the Property
inspector, or go to Modify > Table > Merge Cells.

To merge two or more table cells, select the cells
and either click the Merge icon in the Property
inspector, or go to Modify > Table > Merge Cells.

Page 265
To split a table cell, click to put the insertion
point inside the cell and either click the Merge
icon in the Property inspector, or go to Modify >
Table > Split Cell.

To split a table cell, click to put the insertion
point inside the cell and either click the Split
icon in the Property inspector, or go to Modify >
Table > Split Cell.

Page 274
8. Place your cursor in the third row, and using
Modify > CSS Styles, select date.

8. Place your cursor in the third row, and using
Text > CSS Styles, select date.

Page 275
9. Position your cursor in Row 5 (the last row),
using Text > CSS Styles, select copy from the list.

9. Position your cursor in Row 5 (the last row),
using Text > CSS Styles, select copyr from the
list.

Page 276
11. Type the following in this cell:
{spacebar}This week’s focus is on the
family…

11. Type the following in this cell:
{spacebar}{spacebar}This week’s focus is
on the family…

Page 276
13. Type in the following text at the current
cursor position: {spacebar}A bathroom…

13. Type in the following text at the current
cursor position: {spacebar}{spacebar}A
bathroom…

Page 276 14. Type the following text at the current cursor



14. Type the following text at the current cursor
position: Read more inside…Use the Text >
Align > Right menu item and using the Property
inspector, type in javascript;; in the Link field.

position: Read more inside…Select this text in
the Property inspector, select right alignment,
and type javascript;; in the Link field.

Page 277
15. …Now, select Insert > Table and in the Insert
Table Dialog, specify 5 Rows, 1 Column, 0 for
Cell spacing, Cell padding and Border. Change
width to 75 Pixels.

15. …Now, select Insert > Table and in the Insert
Table Dialog, specify 6 Rows, 1 Column, 0 for
Cell spacing, Cell padding and Border. Change
width to 175 Pixels.

Page 277
16. Place your cursor in the top most cell of this
new table and insert a spacer image 100 pixels
wide and 5 pixels high.

16. Place your cursor in the top most cell of this
new table and insert a spacer image 175 pixels
wide and 5 pixels high.

Page 287
Dreamweaver might not have moveable rulers
you can pull out from the rulers, but it does have
a grid.

Dreamweaver might not have moveable ruler
guides you can pull out from the rulers, but it
does have a grid

Page 307
But this indicates that the grid has outlived its
usefulness, so turn it off by choosing View > Grid
> Show Grid, to toggle the command off.

But this indicates that the grid has outlived its
usefulness, so turn it off by choosing View > Grid
> Show Grid, to toggle both commands off.

Page 317
If you’re thinking ahead, before you create your
layer-based layout you’ll open the Layers panel
(Window > Other > Layers, which opens the
Advanced Layout panel group) and select the Do
Not Allow Overlaps options (see Figure 10.24).

If you’re thinking ahead, before you create your
layer-based layout you’ll open the Layers panel
(Window > Others > Layers, which opens the
Advanced Layout panel group) and select the Do
Not Allow Overlaps options (see Figure 10.24).

Page 323
4. …To keep yourself from accidentally
overlapping them, open the Layers panel and
select Prevent Overlap (Windows > Other >
Layers, or expand the Advanced Layout panel
group).

4. …To keep yourself from accidentally
overlapping them, open the Layers panel and
select Prevent Overlap (Windows > Others >
Layers, or expand the Advanced Layout panel
group).

Page 324
7. …Choose Modify > Convert Layers to Table.

7. …Choose Modify > Convert > Layers to Table.

Page 325
8. …Then choose Modify > Convert Layers to
Table again.

8. …Then choose Modify > Convert > Layers to
Table again.

Page 334
In this exercise, you build a simple HTML form
that includes several <input>.

In this exercise, you build a simple HTML form
that includes several <input> elements.

Page 379
1. With the Site panel open and the site
chapter_12 displayed, from the Site panel’s
menu, choose New > New File.

1. With the Site panel open and the site
chapter_12 displayed, right-click (Mac users
Ctrl-click) in the window and choose New File
from the contextual menu.

Page 410
An update has been made to the CSS Styles panel
in Dreamweaver MX; the Style Editor view has
been added.

An update has been made to the CSS Styles panel
in Dreamweaver MX; the Edit Styles view has
been added.

Page 410
The Style Applier view is also new, and is found
in the classic Dreamweaver panel.

The Apply Styles view is also new, and is found in
the classic Dreamweaver panel.



Page 410
This button is available in either the Style
Applier or Style Editor views.

This button is available in either the Apply Styles
or Edit Styles views.

Page 413
To remove a custom class from the element itself,
select the element and go to the Apply Styles
panel.

To remove a custom class from the element itself,
select the element and go to the CSS Styles panel
in Apply Styles view.

Page 429
Highlight some text on your page, right-click
(Cmd-click) and choose CSS Styles…

Highlight some text on your page, right-click
(Ctrl-click) and choose CSS Styles…

Page 430
Yet another way to access the classes if from the
right-click menu (see Figure 13.20).

Yet another way to access the classes is from the
contextual menu (see Figure 13.20).

Page 435
8. In the CSS Styles panel, double-click the
table.positioning class.

8. In the CSS Styles panel, click the positioning
class.

Page 454
1. …To get your workspace ready for layer work,
choose Window > Other > Layers (or press F2) to
show the layers panel.

1. …To get your workspace ready for layer work,
choose Window > Others > Layers (or press F2)
to show the layers panel.

Page 466
2. …When the dialog box comes up, set it to
Create New Custom Style…

2. …When the dialog box comes up, set it to
Make New Custom Style…

Page 469-Note
See Chapter 32, “Technical Issues,” for more on
using the Quick Tag Editor and setting its
preferences.

See Chapter 3, “Creating and Working with
Documents,” for more on using the Quick Tag
Editor and setting its preferences.

Page 470
That’s the power of CSS2 at work.

That’s the power of CSS at work.

Page 473
3. …Go to the Positioning category and set the
Position pop-up menu to absolute (see Figure
14.27).

3. …Go to the Positioning category and set the
Position pop-up menu to absolute (see Figure
14.27). Set left and top values to 0 pixels.

Page 474
From the pop-up list of available styles, choose
heading.

From the pop-up list of available styles, choose
title.

Page 477
In the CSS Styles panel, click the Attach Style
Sheet button and link to the sitestyles.css
document.

In the CSS Styles panel, click the Attach Style
Sheet button and link to the siteStyles.css
document.

Page 508
In this exercise, we will attach a behavior to an
image. Specifically, we will attach a Popup Menu
behavior to an image.

In this exercise, we will attach a behavior to an
image. Specifically, we will attach a Popup
Message behavior to an image.

Page 512
2. Insert the navigation.fig image (from the
chapter_16 folder on the CD) onto the page.
Make sure that it is selected on the page.

2. Insert the navigation.fig image (from the
chapter_16 folder on the CD) onto the page.
Make sure that it is selected on the page. In the
Property inspector, name the image home.

Page 513
5. …In the Link Field, type in
http://www.macromedia.com.

5. …In the Link Field, type in
http://www.macromedia.com/dreamweaver.

Page 521
1. In a new document, go to Insert > Interactive
Images > Rollover Image.

1. Create a new document and save it as
rollover_test.html. Go to Insert > Interactive
Images > Rollover Image.

Page 522
12. …For Set Source To, click the Browse button
and choose gcanal2.jpg from the
chapter_16/samples/images folder.

12. …For Set Source To, click the Browse button
and choose gcanal2.jpg from the chapter_16
folder.

Page 546
Search for double quotes (“) and replace with
single quotes (‘).

Search for double quotes (") and replace with
single quotes (').



Page 547-Note
If your pasted code contains incorrect quote
marks, the improperly terminated string literals
will turn blue. If the quote marks are correct, the
entire function call (everything after
onMouseOver=) will be pink.

If your pasted code contains incorrect quote
marks, the improperly terminated string literals
will turn black. If the quote marks are correct,
the entire function call (everything after
onMouseOver=) will be blue.

Page 601
You can set them up to match the clown
animation (slide out onMouseOver, slide away
onMouseOut), or create your own different
animation.

You can set them up to match the clown
animation, or create your own different
animation.

Page 620
width = 250
height = 345

(The true height of the movie is 329 pixels, …

width = 340
height = 265

(The true height of the movie is 240 pixels, …

Page 621
Different RealMedia elements can even be
combined into mulitmedia presentations using an
offshoot of XML called SMIL…

Different RealMedia elements can even be
combined into mulitmedia presentations using an
XML-based language called SMIL…

Page 626
3. …(To create a completely empty file in
Dreamweaver, go to File > New and, from the
New Document dialog box, choose Script
Files/Text File.)

3. …(To create a completely empty file in
Dreamweaver, go to File > New and, from the
New Document dialog box, choose Other/Text.)

Page 639
If you want controllable video files, build the
controls into a QuickTime file or put the
QuickTime video into Shockwave.

If you want controllable video files, build the
controls into a QuickTime file or put the video
into a Flash movie.

Page 645
Base adds the base parameter, and should be set
to the name of the folder, if any, that contains
the Java applet files.

Base adds the base parameter, and should be set
to the URL of the folder, if any, that contains the
Java applet files.

Page 647-Table 19.11
For each occurrence of the parameter, the value
must be a vb] delimited string where the first
item is the quote…

For each occurrence of the parameter, the value
must be a vertical bar (|) delimited string where
the first item is the quote…

Page 669
2. …You should get a lovely preview of the
animated background, but the content layers
won’t show, even in IE/Windows.

2. …You should get a lovely preview of the
animated background, but the content layers
won’t show correctly, even in IE/Windows.

Page 671
5. …In other browsers and platforms, you’ll just
see the background movie.

5. …In other browsers and platforms, you’ll just
see the background movie, or the movie and
partial page contents.

Page 761
This is because these two asset types do not have
files associated with them; they are simply strings
of text inside files.

This is because these two asset types do not have
files associated with them; they are simply strings
of code inside files.

Page 773
Missing last two sentences in step 2.

For this purpose, create a new folder on
computer. Call it chapter_23.



Page 810
If you haven’t done so already, copy the files from
the chapter_22 folder on the CD to your hard
drive. Define a site called Grandpa’s Ice Cream,
with chapter_22/local as the local root folder
and chaptter_22/remote  as the remote folder.

If you haven’t done so already, copy the
chapter_22 folder on the CD to your hard
drive. Define a site called Grandpa’s Ice Cream,
with chapter_22 as the local root folder and
chaptter_23  as the remote folder.

Page 882
This will install Apache 1.3.22.

This will install Apache 1.3.22 or higher.

Page 882
2. In the web Sharing section, click the Start
button to start web sharing (see Figure 26.13).
Note that you need to be logged in as an
administrator to do this.

2. If you’re running Jaguar, click the Personal
Web Sharing checkbox. For systems prior to
Jaguar, click the Start button in the Web Sharing
section (see Figure 26.13). Note that you need to
be logged in as an administrator to do this.

Page 883
Figure 26.13 Starting web sharing in OS X
launches Apache.

Figure 26.13 Starting web sharing in OS X
launches Apache. (OS 10.1 shown.)

Page 886
Figure 26.16 replacement.



Page 906
You also can create a recordset by going to Insert
> Application panel, and choosing the Recordset
object.

You also can create a recordset by going to Insert
> Application bar, and choosing the Recordset
object.

Page 911
6. …(Use the Image object from the Insert >
Common panel.)

6. …(Use the Image object from the Insert >
Common bar.)

Page 916
3. From the Insert > Application panel, choose
the Repeat Region object.

3. From the Insert > Application bar, choose the
Repeat Region object.

Page 927
7. Go to the Application Server page.

7. Go to the Testing Server category.

Page 948
In this exercise, you add dynamic elements to the
catalog.asp page, which already has its static
layout element in place.

In this exercise, you add dynamic elements to the
catalog.cfm page, which already has its static
layout element in place.

Page 958
3. From the Insert > Application panel, choose
the Repeat Region object.

3. From the Insert > Application bar, choose the
Repeat Region object.

Page 966
4. Finally, type the following (no typos!):
sudo perl -p -i.bak -e ‘s%#(AddType \S+-
php[ -])%$1%I’ httpd.conf

4. Finally, type the following (no typos!):
echo 'echo "AddType application/x-httpd-php
.php" >>
/etc/httpd/httpd.conf' | sudo sh –s

For systems prior to Jaguar, type:
sudo perl -p -i.bak -e ‘s%#(AddType \S+-
php[ -])%$1%I’ httpd.conf

When you’re sure the code is correct, press Enter
or Return.

Page 968
See Appendix B for detailed instructions on all of
these tasks.

See Appendix C for detailed instructions on all of
these tasks.

Page 977
You also can create a recordset by going to Insert
> Application panel, and choosing the Recordset
object.

You also can create a recordset by going to Insert
> Application bar, and choosing the Recordset
object.

Page 980
Figure 30.12 replacement.



Page 981-Tip
In the Applications panel group, open the Server
Behaviors panel, and you’ll see one behavior for
every dynamic text element.

In the Application panel group, open the Server
Behaviors panel, and you’ll see one behavior for
every dynamic text element.

Page 1013-Note
Dreamweaver uses the files in the application
server to generate previews.

Dreamweaver uses the files in the testing server
to generate previews.

Page 1070
If the expected value is a color, the color palette
will appear (use the arrow keys to navigate
through the swatches).

If the expected value is a color, the color picker
will appear (use the arrow keys to navigate
through the swatches).

Page 1079
<input type=”checkbox” name=”check”></td>

<input type=”checkbox” name=”check”>Lorem
Ipsum</td>

Page 1090
Dreamweaver is expecting a text value, for
instance, no code hint will be given; if a color
value is expected, the color pallet will appear;…

Dreamweaver is expecting a text value, for
instance, no code hint will be given; if a color
value is expected, the color picker will appear;…

Page 1094
1. Start by choosing Edit > Edit Tag Libraries, to
open the Tag Library Editor.

1. Start by choosing Edit > Tag Libraries, to open
the Tag Library Editor.

Page 1095
8. …Go to Edit > Edit Tag Libraries, to open the
Tag Library Editor.

8. …Go to Edit > Tag Libraries, to open the Tag
Library Editor.

Page 1096
Figures 33.33 an d33.34 replacements.

Figure 33.33



Figure 33.34

Page 1105
Open the Find and Replace dialog box, and set it
up as shown in Figure 33.40.

To do this, perform a search with the settings as
shown in Figure 33.40.

Page 1107
4. One of our headers has the text pop., but
you’ve changed your mind and want it to say
Population.

4. One of our header cells has the text pop., but
you’ve changed your mind and want it to say
Population.

Page 1112
If you’re frustrated by the viewing restrictions,
you can customize the behavior it present a text
area rather than a text field in its dialog box by
editing the calljavascript.htm file (located in
the Dreamweaver application folder, in
Configuration/Behaviors/Actions).

If you’re frustrated by the viewing restrictions,
you can customize the behavior it present a text
area rather than a text field in its dialog box by
editing the Call JavaScript.htm file (located in
the Dreamweaver application folder, in
Configuration/Behaviors/Actions).

Page 1115
Figure 33.49 replacement.



Page 1137
2. Open the History panel by choosing Windows
> Other > History, so you’ll be ready to work
with it.

2. Open the History panel by choosing Window >
Other > History, so you’ll be ready to work with
it.

Page 1232
cd /users/fred/mysqul
./scripts/mysql_install_db

cd /users/fred/mysqul
./scripts/mysql_install_db -force.

CD
A copy of the antiques database folder
(antiques_mysql folder) was inadvertently placed
in the Chapter 30 files.  Please do not use this
database for the introduction to MySQL in
Appendix C.

This errata sheet is intended to provide updated technical information.
Spelling and grammar misprints are updated during the reprint process,

but are not listed on this errata sheet.


