
Carol Freeman Nikon F5, Fujia Provia ƒ stop: ƒ5.6 exposure: 1/60
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Okay, did you catch that reference to the band The Fixx

in the title? You did? Great. That means that you’re at

least in your mid-thirties to early forties. (I myself am

only in my mid- to early twenties, but I listen to oldies

stations just to keep in touch with baby boomers and

other people who at one time or another tried to

break-dance.) Well, the Fixx had a big hit in the early

’80s (around the time I was born) called “One Thing

Leads to Another,” and that’s a totally appropriate title

for this chapter because one thing (using a digital cam-

era) leads to another (having to deal with things like

digital noise, color aliasing, and other nasties that pop

up when you’ve finally kicked the film habit and gone

totally digital). Admittedly, some of the problems we

bring upon ourselves (like leaving the lens cap on; or

forgetting to bring our camera to the shoot, where the

shoot is, who hired us, or what day it is; or we immersed

our flash into a tub of Jell-O, you know—the standard

stuff). And other things are problems caused by the

hardware itself (the slave won’t fire when it’s submerged

in Jell-O, you got some Camembert on the lens, etc.).

Whatever the problem, and regardless of whose fault it

is, problems are going to happen, and you’re going to

need to fix them in Photoshop. Some of the fixes are

easy, like running the “Remove Camembert” filter, and

then changing the Blend Mode to Fromage. Others will

have you jumping through some major Photoshop

hoops, but fear not, the problems you’ll most likely run

into are all covered here in a step-by-step format that

will have you wiping cold congealed water off your flash

unit faster than you can say, “How can Scott possibly be

in his mid-twenties?”.

The Big Fixx
digital camera image problems
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Compensating for
“Too Much Flash”

Don’t ya hate it when you open a photo and realize that either (a) the flash
fired when it shouldn’t have; (b) you were too close to the subject to use the
flash and they’re totally “blown out”; or (c) you’re simply not qualified to use
a flash at all, and your flash unit should be forcibly taken from you, even if
that means ripping it from the camera body? Here’s a quick fix to get your
photo back from the “flash graveyard” while keeping your reputation, and
camera parts, intact.

Step One:
Open the photo that is suffering from 
“flashaphobia.” In the example shown
here, the flash, mounted on the camera
body, washed out the entire subject. 

Step Two:
Make a copy of the photo by pressing
Command-J (PC: Control-J). This will 
create a layer titled “Layer 1.”
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Step Three: 
Next, change the Blend Mode of Layer 1
from Normal to Multiply from the pop-
up menu at the top of the Layers palette.
This Blend Mode has a “multiplier” effect,
and brings back a lot of the original
detail the flash “blew out.”

Step Four: 
If the photo still looks washed out, you
may need to make a duplicate of Layer 1.
Just press Command-J (PC: Control-J),
and this layer will be duplicated; this
duplicate will already be in Multiply
mode. Incidentally, because of the
immutable laws of life, chances are that
creating one layer with its Blend Mode
set to Multiply won’t be enough, but
adding another layer (in Multiply mode)
will be “too much.” If that’s the case, just
go to the Layers palette and lower the
Opacity setting of the top layer to 50%
or less—this way, you can “dial in” just
the right amount, and get the amount
of flash looking right. 
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Step One: 
Open a photo that contains visible digital
noise (in this case, it’s a shot taken in low
light, and those “red, green, and blue” dots
appear throughout the photo).

Step Two: 
Go under the Image menu, under Mode,
and choose Lab Color. Switching to Lab
Color is a non-destructive mode change, and
won’t damage your RGB photo in any way—
you can switch back and forth between RGB
and Lab Color any time. You won’t see any
visible difference in your image onscreen,
but if you look up in the title bar for your
document, you’ll see “Lab” in parentheses, 
to let you know you’re in Lab Color mode.

Step Three: 
When you’re in RGB mode, your image is
made up of three channels: a Red, a Green,
and a Blue channel. When these three are
combined, they create a full-color photo.
When you convert to Lab Color, Photoshop
composes your photo differently—although
it looks the same, it’s now made up of a
Lightness channel (the luminosity of the
photo, where the detail is held) and two 
color channels, named “a” and “b.” Go to
the Channels palette and you’ll see these
channels. Click on the “a” channel (as shown). 

Dealing
with

Digital
Noise

If you shoot in low-light situations, you’re bound to encounter digital noise.
Is there anything worse than these large red, green, and blue dots that
appear all over your photo? Okay, besides that “crazy music” those
teenagers play, like Limp Bizkit or…well…Limp Bizkit, is there anything
worse? This digital noise (often called “Blue channel noise,” “high ISO
noise,” “color aliasing,” or just “those annoying red, green, and blue dots”)
can be reduced. Here’s how:
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Step Four: 
Now that you’re affecting only the “a”
channel (which consists of color data),
go under the Filter menu, under Blur,
and choose Gaussian Blur. When the
Gaussian Blur dialog appears (shown at
left), increase the Radius (amount of
blur) until you see the dots pretty much
disappear, and then click OK. In this
case, I increased the Radius to 2 pixels.

Step Five: 
Now, in the Channels palette, click on
the “b” channel (as shown at left). Press
Command-F (PC: Control-F) to apply the
Gaussian Blur filter to this “b” channel
with the exact same setting we used on
the “a” channel. Because you’re using the
re-apply shortcut, you won’t see the
Gaussian Blur dialog box—it will just
automatically apply the filter for you.

Step Six: 
Go back under the Image menu, under
Mode, and choose RGB to return to RGB
mode. You’ll notice that the spots are
much less pronounced because they no
longer appear in red, green, and blue.
You blurred the color channels, and by
doing so, you eliminated those colors
that are distracting to the eye. The effect
appears much more muted, and in some
cases (depending on the photo) will
nearly disappear.
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Removing
Color

Aliasing

Here’s another quick trick Jim DiVitale and Kevin Ames use for reducing the
color aliasing (digital noise) that often appears in digital photos shot in low-
lighting situations. 

Step One:
Open the photo that has visible color
aliasing. Go under the Filter menu, under
Blur, and choose Gaussian Blur. Drag the
Radius slider all the way to the left, then
start dragging to the right until the color
aliasing is blurred enough that you can’t
see it. Click OK to apply the blur.

Step Two:
Go under the Edit menu and choose
Fade Gaussian Blur. When the Fade 
dialog appears, change the Fade Mode to
Color (as shown) and the color aliasing
will disappear. It’s quick, it’s easy, and it
works. It’s also an ideal candidate for
becoming an action, so you can remove
color aliasing with just one click.
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Step One: 
Open a photo where shooting with the
flash has ruined part of the image (like
the image shown here taken during a
seminar presentation, where the back
ten rows are lit by the flash, when they
should be dark. Just the stage lit by the
stage lighting should appear out of the
darkness).

Fixing Photos
Where You 
Wish You Hadn’t
Used Flash

Step Two: 
Press the letter “L” to get the Lasso
tool, and draw a loose selection over
the area where the flash affected the
shot. In the image shown here, the lasso
encompasses a number of rows in the
back of the theater. 

There’s a natural tendency for some photographers to react to their immediate
surroundings, rather than what they see through the lens. For example, if you’re
shooting an indoor concert, there are often hundreds of lights illuminating the
stage. However, some photographers think it’s one light short—their flash,
because where they’re sitting, it’s dark. When you look at your photos later, you
see that your flash lit everyone in front of you (which wasn’t the way it really
looked—the crowd is usually in the dark), which ruins an otherwise great shot.
Here’s a quick fix to make it look as if your flash never fired at all. 

Continued
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Step Three: 
In the next step, we’re going to adjust
the tonal range of this selected area,
but we don’t want that adjustment to
appear obvious. We’ll need to soften
the edges of our selection quite a bit 
so our adjustment blends in smoothly
with the rest of the photo. To do this,
go under the Select menu and choose
Feather. When the Feather Selection
dialog box appears, enter 25 pixels to
soften the selection edge. (By the way,
25 pixels is just my guess for how much
this particular selection might need.
The rule of thumb is the higher the 
resolution of the image, the more
feathering you’ll need, so don’t be
afraid to use more than 25 if your edge
is visible when you finish.)

Step Four: 
It will help you make a better 
adjustment if you hide the selection
border (we call it “the marching ants”)
from view. Note: We don't want to
Deselect—we want our selection to
remain intact but we don’t want to 
see the annoying border, so press
Command-H (PC: Control-H) to hide
the selection border. Now, press
Command-L (PC: Control-L) to bring up
the Levels dialog. At the bottom of the
dialog, drag the right Output Levels
slider to the left to darken your selected
area. Because you’ve hidden the selec-
tion border, it should be very easy to
match the surroundings of your photo
by just dragging this slider to your left.
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Step Five: 
When the photo looks about right, click
OK to apply your Levels adjustment.
Then, press Command-H (PC: Control-H)
to make your selection visible again 
(this trips up a lot of people who, since
they don’t see the selection anymore,
forget it’s there, and then nothing reacts
as it should from that point on).

Step Six: 
Last, press Command-D (PC: Control-D)
to Deselect and view your repaired
“flash-free” photo.
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Step One: 
Open an underexposed photo. 
The photo shown here, shot
indoors without a flash, could’ve
used either a fill flash or a better
exposure setting. 

Fixing
Underexposed

Photos

This is a tonal correction for people who don’t like making tonal corrections
(over 60 million Americans suffer from the paralyzing fear of MTC [Making
Tonal Corrections]). Since this technique requires no knowledge of Levels or
Curves, it’s very popular, and even though it’s incredibly simple to perform, it
does a pretty incredible job of fixing underexposed photos. 

Step Two: 
Press Command-J (PC: Control-J) to
duplicate your Background layer
(this duplicate will be named Layer 1
by default). On this new layer,
change the Blend Mode in the Layers
palette from Normal to Screen to
lighten the entire photo.
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Step Three: 
If the photo still isn’t properly
exposed, just press Command-J (PC:
Control-J) and duplicate this Screen
layer until the exposure looks about
right (this may take a few layers, but
don’t be shy about it—keep copying
layers until it looks right).

Step Four: 
There’s a good chance that at
some point your photo will still
look a bit underexposed, so you’ll
duplicate the layer again, but now
it looks overexposed. What you
need is “half a layer.” Half as much
lightening. Here’s what to do:
Lower the Opacity of your top
layer to “dial in” the perfect
amount of light, giving you some-
thing between the full intensity of
the layer (at 100%) and no layer at
all (at 0%). For half the intensity,
try 50% (did I really even have to
say that last line? Didn’t think so).
Once the photo looks properly
exposed, choose Flatten Image
from the Layers palette’s pop-
down menu.
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When You
Forget
to Use 

Fill Flash

Wouldn’t it be great if Photoshop had a “fill flash” brush, so when you
forgot to use your fill flash, you could just paint it in? Well, although it’s
not technically called the fill flash brush, you can create your own brush
and get the same effect. Here’s how:

Step Two: 
Drag the middle Input Levels slider
(the gray one) to the left until your
subject looks properly exposed.
(Note: Don’t worry about how the
background looks—it will probably
become completely “blown out,” but
you’ll fix that later; for now, just
focus on making your subject look
right.) If the midtone slider doesn’t
bring out the subject enough, you
may have to increase the highlights
as well, so drag the far-right Input
Levels slider to the left to increase
the highlights. When your subject
looks properly exposed, click OK.

Step One: 
Open a photo where the subject 
or focus of the image appears in
shadows. Go under the Image 
menu, under Adjustments, and
choose Levels. 
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Step Three: 
Go under the Window menu and
choose History to bring up the
History palette. This palette keeps a
running “history” of the last 20
adjustments you’ve made to your
photo. In this instance, there should
be only two entries (called “History
States”). Open should be the first
State, followed by Levels, showing
that you opened the photo and then
made a Levels adjustment.

Step Four: 
In the History palette, click on the
State named “Open.” This will
return your photo to how it looked
when you originally opened the
image (in other words, it will look
the way it did before you adjusted
the Levels).

Continued
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Step Five: 
In the History palette, click in the
first column next to the grayed-out
State named “Levels.” An icon that
looks like Photoshop’s History Brush
will appear in the column, showing
that you’re going to be painting from
what your image looked like after
you used Levels. 

Step Six: 
Choose the History Brush tool from
the Toolbox (as shown at right), and
choose a soft-edged brush from the
Brush Picker in the Options Bar.
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Step Seven: 
Begin painting with the History
Brush over your subject, avoiding the
background area entirely. (Here, I’m
painting over the left side of the 
subject’s face.) As you paint, you’ll
notice that you’re actually painting
in the lightened version of the sub-
ject you adjusted earlier with Levels.

Step Eight: 
Continue painting with the History
Brush until your subject looks as if
you used a fill flash. When you’re
painting, if it appears too intense,
just lower the Opacity of the History
Brush up in the Options Bar. That
way, when you paint, the effect will
appear less intense. You can see the
final repair here at left, with the
background unchanged, but the 
subject in shadows is “brought out.”
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Instant
Red Eye

Removal

When I see a digital camera with the flash mounted directly above the lens, I
think, “Hey, there’s an automated red-eye machine.” If you’re a pro, you prob-
ably don’t have to deal with this as much, because your flash probably isn’t
mounted directly above your lens—you’re using bounce flash, holding the
flash separately, you’ve got studio lights, or one of a dozen other techniques.
But even when the pros pick up a “point-and-shoot,” red eye can find them.
Here’s the quick “I-just-want-it-gone” technique for getting rid of red eye fast. 

Step One: 
Open a photo where the subject has
red eye. Zoom in on the eyes by
dragging a rectangle around them
with the Zoom tool (the Magnifying
Glass tool).

Step Two: 
Switch to the Brush tool, and choose
a soft-edged brush that’s nearly the
same size as the part of the eye you
want to correct. Press the letter “d”
to set your Foreground color to
black. Then, in the Options Bar,
change the Blend Mode of the Brush
tool from Normal to Color, as shown
at right.
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Step Four: 
Paint over all the other eyes in 
the photo, and you’re done—and
best of all, the entire process takes
just seconds. 

Step Three: 
Use the Brush tool and paint direct-
ly over the red eye (you can even
dab if you’d like). As you paint, the
red disappears because with the
Brush tool’s Blend Mode set to
Color, it desaturates (removing the
color from) anywhere you paint. 
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Removing
Red Eye and

Recoloring
the Eye

This technique is a little more complicated (not hard; it just has a few
more steps), but the result is more professional because you’re not just
going to remove the red eye (like in the previous “instant red-eye
removal” trick) and replace it with the more pleasing “gray eye.” Instead,
we’re going to restore the eye to its original color.

Step One: 
Open a photo where the subject has
red eye. 

Step Two: 
Zoom in close on one of the eyes
using the Zoom tool (the Magnifying
Glass tool). Note: You might not
want to do this late at night if you’re
home alone, because seeing a huge
scary eye on your screen can really
give you the willies. 
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Step Three: 
Press the “w” key to switch to the
Magic Wand tool, and click within
the red area of one of the eyes. One
click may select all the red in the eye,
but if it doesn’t, hold the Shift key
and click the Magic Wand again in
an area of red that wasn’t selected
(holding the Shift key lets you add to
your current selection). If the Magic
Wand selects too much, go up to the
Options Bar, lower the Threshold
number, and try again. After one
eye’s red area is selected, scroll over
to the other eye, hold the Shift key,
and select it the same way so that
both red-eye areas are selected. 

Step Four: 
Now, press Shift-Command-U (PC:
Shift-Control-U) to desaturate all the
color from these selected red areas,
leaving the eyes looking pretty gray.
It’s better than red, but you might
want to touch it up a bit, and make
it a bit darker, which we’ll do in the
next step.

Continued
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Step Five: 
Press the “d” key to set your
Foreground color to black. Get 
the Brush tool and choose a small, 
soft-edged brush; then, up in the
Options Bar, lower the Opacity 
setting to 20%. 

Step Six: 
Zoom out a bit by pressing
Command-– (the minus sign) (PC:
Control-–) until you can see both
eyes onscreen. Paint just a couple of
quick strokes over the selected areas
of the eye to darken them, but stop
before they turn completely black—
you just want a good dark gray. You
don’t have to worry about painting
into other areas of the eye, because
your selection should still be in place
while you’re painting. 
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Step Seven: 
Once the eyes look dark gray, you
can Deselect by pressing Command-
D (PC: Control-D). Press the “L” key
to switch to the Lasso tool, and
draw a loose selection around the
entire iris of the left eye (as shown).
The keyword here is loose—stay
well outside the iris itself, and don’t
try to make a precise selection.
Selecting the eyelids, eyelashes, etc.
will not create a problem. Hold the
Shift key and select the right eye in
the same fashion.

Step Eight: 
After you have a loose selection
around both irises, press Command-J
(PC: Control-J) to put a copy of the
eyes up on their own layer above the
Background, as Layer 1.

Continued
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Step Nine: 
While you’re on this “eyes” layer, 
go under the Image menu, under
Adjustments, and choose
Hue/Saturation. In the dialog, 
click on the Colorize checkbox 
(in the bottom-right corner). Now
you can choose the color you’d 
like for the eye by moving the Hue
slider. The area you removed earlier
will remain the dark gray color, and
only the iris will be affected by your
colorization. In this case, we’re
going to colorize the iris blue. 
Don’t worry about the color being
too intense at this point—we can
totally control that later—so if you
want blue eyes, choose a deep blue
and we’ll dial in the exact blue later.
Click OK to apply the blue to the
irises and the area around them as
well. (Don’t let this freak you out
that other areas right around the
iris appear blue. We’ll fix that in 
the next step.)

Step Ten: 
Press the “e” key to switch to 
the Eraser tool, make sure that in
the Options Bar the Mode is set 
to Brush, choose a hard-edged
brush, and then erase the extra
areas around the iris from your
loose selection. This sounds much
harder than it is—it’s actually very
easy—just erase everything but the
blue iris. Don’t forget to erase over
the whites of the person’s eyes.
Remember, the eyes are on their
own layer, so you can’t accidentally
damage any other parts of 
the photo. 
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Step Twelve: 
To finish the red-eye correction 
and recolor, press Command-E 
(PC: Control-E) to merge the colored
eye layer with the Background layer,
completing the repair.

Step Eleven:
If the eye color seems too intense
(and chances are, it does), we 
can lower the intensity in the 
Layers palette by simply lowering
the Opacity slider until the eyes
look natural. 
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Repairing
Keystoning

Without the
Crop Tool

Keystoning is often found in photos with buildings or tall objects, where
the buildings look as if they’re falling away from the viewer (giving the
impression that the tops of these buildings are narrower than their bases).
The Crop tool has a Perspective function that can be used to fix these dis-
tortions, but actually I’m going to recommend that you don’t use it,
because it doesn’t offer a preview of any kind—you’re just guessing, so use
this technique instead.

Step One: 
Open an image that has a lens 
distortion problem (such as the
photo shown at right, where the
building seems to be leaning away
from the viewer). 

Step Two: 
Grab the bottom-right corner of
your image window and drag out-
ward to reveal the gray canvas
background. Press Command-A
(PC: Control-A) to Select All and
then press Command-T (PC:
Control-T) to bring up the Free
Transform function. Grab the 
center point of the bounding box
and drag it straight downward until
it touches the bottom-center Free
Transform point (as shown at right
at the cursor location near the bot-
tom of the photo). 
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Step Three: 
Press Command-R (PC: Control-R) 
to make Photoshop’s rulers visible.
Click-and-drag a guide out from the
left ruler into your photo (we’ll use
this straight guide to help us line up
our building). In the example shown
at left, I placed the guide where I
thought the top corner of the build-
ing should be aligned.

Step Four:
Once your guide is in place, hold
the Command key (PC: Control
key) and adjust the top left and
right corner points of the bound-
ing box until the corner of the
building aligns with your guide.
Making this correction can some-
times make your building look  
a bit “smushed” and “squatty” (my
official technical terms), so you can
release the Command/Control key,
grab the top-center point, and 
drag upward to stretch the photo
back out and fix the “squattyness”
(again, technically speaking). 

Continued
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Step Five: 
When the photo looks right, press
Return (PC: Enter) to lock in your
transformation. (Note: By repairing
this problem with Free Transform,
you got to see an onscreen preview
of what you were doing, which the
Crop tool’s Perspective feature
doesn’t offer.) Now you can drag
your guide back to the rulers, and
hide the rulers again by pressing
Command-R (PC: Control-R).
There’s still one more thing you’ll
probably have to do to complete
this repair job.

Step Six: 
If, after making this adjustment, the
building looks “round” and “bloat-
ed,” you can repair that problem by
going under the Filter menu, under
Distort, and choosing Pinch. Drag
the Amount slider to 0%, and then
slowly drag it to the right (increas-
ing the amount of Pinch), while
looking at the preview in the filter
dialog, until you see the roundness
and bloating go away. (In the exam-
ple shown here, I used 5% for my
Amount setting.) 
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The same photo after repairing
the distortion and bloating.

Step Seven: 
When it looks right, click OK to 
complete your keystoning repair. 
A before and after are shown here.

In the original photo, the building
appears to be “falling away.”
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Step One: 
Open a photo with a visible moiré 
pattern (like the one shown here).

Removing Moiré 
Patterns from

Coats, Shirts, Etc.

There are certain fabrics or garments, usually hideously ugly ones (kidding),
that create a visible pattern when photographed with a digital camera.
Perhaps the most common of these patterns, called moiré pattern, is one
that shows up in garments and appears as a rainbow of colors. It’s very
hard to repair—that is, unless you know this great trick. (Thanks to 
David Cuerdon who showed it to me.)

Step Two: 
Press the letter “L” to switch to the Lasso
tool, and draw a selection around the
areas of the image that have a visible
moiré pattern (as shown at right).
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Step Three: 
To hide our “tracks” a bit, we’ll soften
the edges of our selection. This will help
the correction we’re about to apply
blend in better with the rest of the
image. Go under the Select menu and
choose Feather. When the Feather
Selection dialog appears, enter 1 or 
2 pixels and click OK to soften the edge 
of your selection.

Step Four: 
Press Command-J (PC: Control-J) to 
copy the selected area onto its own 
layer above the Background layer.

Step Five: 
Go under the Filter menu, under Blur,
and choose Gaussian Blur. When the
Gaussian Blur dialog appears, drag the
Radius slider all the way to the left and
then slowly drag it to the right until 
you see the moiré pattern disappear
(you’re basically “blurring” it away). 
Click OK. The photo will still look 
pretty bad because there’s one more
step we have to perform before it all
comes together. 

Continued
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Step Six: 
Go to the Layers palette and change
the Blend Mode of this layer from
Normal to Color. When you do this,
the moiré pattern will be hidden by the
blur and the object will look normal
again, yet you didn’t destroy any of its
detail. How cool is that?

Before

After
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