
Maya gives you many ways to move, rotate,
and scale objects around a scene, and many
shortcuts for completing these common
tasks. These actions, known as transforma-
tions, can be performed in a couple of differ-
ent ways: You can type new coordinates or
values in the Channel Box or use one of the
many manipulation tools (Figure 4.1) to
drag an object freely around the scene or
constrain it to an axis.

Using the same tools you would employ to
manipulate objects in the scene, you can
also manipulate parts of an object, known 
as components. Each object type has its own
components that can be translated (Figure
4.2), rotated, and/or scaled to change their
look and position, in turn changing the
appearance of the object.

Most tools include advanced features
(shown in the Tool Options) that you can
explore as your knowledge base grows. The
duplication options provide a good example
of this. Once you get used to using them,
you can employ a number of advanced
options like duplicating an object multiple
times throughout your scene, or using them
to construct and mirror objects.
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Figure 4.1 Maya’s manipulation tools.

Figure 4.2 The Move tool’s Translation manipulator
is used to move objects and components around
the scene.

Arrow selection

Lasso selection

Move

Rotate

Scale

Soft Modification

Show Manipulator

Last tool used 

Universal Manipulator

Paint selection



Moving, Rotating, and
Scaling Objects
Maya provides multiple tools for moving,
rotating, and scaling objects and compo-
nents. The Universal Manipulator tool can
perform all of these operations at once,
which can be helpful when an object
requires all three transformations. We’ll
discuss the Universal Manipulator tool in
more detail later in this chapter. 

Each of these tools, including the Universal
Manipulator tool, has axes that you can grab
and move to transform an object. These
axes, called manipulators (Figure 4.3), let
you translate (move), rotate, or scale the
object. Manipulators make it easy to con-
strain objects along a particular axis: You
click and drag the colored line for the axis
along which you want to constrain the
object. The colors remain consistent for
each tool. RGB colors coincide with the x-y-z
axes (Figure 4.4): The manipulator’s x axis
is red, the y axis is green, and the z axis is
blue. If you forget an axis’s color, check the
View axis in the lower left-hand corner of
each pane or the View Compass at upper
right (Figure 4.5). The axis selected on the
manipulator is always yellow.
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Rotate
manipulator

Move
manipulator
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Figure 4.5 Check the View axis in the lower-left corner
of each pane to remind yourself which color is associ-
ated with each axis.

Figure 4.4 RGB colors match the x-y-z axes.
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In addition to constraining an object along
an axis, you can freely manipulate the object
by clicking and dragging the square in the
middle of the Move, Scale, and Universal
Manipulator tools (Figure 4.6), or by
clicking and dragging anywhere inside the
Rotate manipulator.

To get precise results, you can also use the
Channel Box for numerical entry. The Channel
Box allows direct access to any of the attrib-
utes (translation axis, rotation axis, and
scale values) that the translation tools affect.

Each of the tools in the toolbar—with 
the exception of the Lasso tool, the Soft
Modification tool, and the Universal
Manipulator—has an associated shortcut
that coincides with qwerty keys on the key-
board. You can press a tool’s key (or, in the
case of the Universal Manipulator, the key
combination) to turn on its manipulator.

The shortcut keys and the manipulators
they turn on are as follows (Figure 4.7):

q Arrow selection tool

w Move tool

e Rotate tool

r Scale tool

c+t Universal Manipulator

t Show Manipulator

y Last tool used
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✔ Tip

■ Be aware that these keys won’t work if
the Caps Lock key is on. Maya is case
sensitive: Capitals represent different
hotkeys with different functions mapped
to them. For example, the Move, Rotate,
and Scale tools’ associated keyboard

shortcuts are q , e , and r , respectively.
However, when those same keyboard
letters are capitalized, they set an ani-
mation keyframe on the translation,
rotation, or scale channels instead (key-
frames are discussed in Chapter 12).

Figure 4.6 The Universal Manipulator combines the
common functions of the Move, Scale, and Rotate tools.

Figure 4.7 The manipulation tools and
their shortcut keys.

Arrow selection q

Lasso selection

Move w

Rotate e

Scale r

Soft Modification

Show Manipulator t

Last tool used y

Universal Manipulator c+t

Paint selection



To translate an object or component
using the Move tool:

1. Select an object or component by
clicking it.

2. Press w , or click the Move tool icon 
in the toolbar.

The Move manipulator becomes visible
on the object or component (Figure 4.8).

3. Click and drag the manipulator’s arrow
in the direction you want the object to
move (Figure 4.9).

This action translates the object along
the selected axis.

or

Hold down s , and then, with the mid-
dle mouse button, click and drag in the
direction you want the object to move
(Figure 4.10).
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Figure 4.8 The Move manipulator is used to move the
object around the scene.

Figure 4.9 Click and drag the axis to which you want
the object constrained so that you can maintain
precise control over the surface’s position. This is
particularly useful in the Perspective view.

New position Original position

Axis manipulator



This action selects the appropriate
manipulator axis and translates the
object in that direction. This is particu-
larly useful if you’ve created an object at
the origin but moved the camera away
from the grid. You can pull the object
into your camera view if you know the
direction of the origin.

or

To translate the object freely, click and
drag the center of the manipulator, and
the motion won’t be constrained on 
any axis. 

✔ Tips

■ You’ll usually want to avoid using free
translations for large adjustments in 
the Perspective view. The nature of 
the view can lead to translations in
unwanted directions.

■ You can also hold down x to activate
grid snap. In addition, if you drag with
the middle mouse button anywhere on
the grid, the object snaps to that location.

■ You can use the + and - keys to
enlarge or shrink the manipulators.

■ From anywhere in a view pane, you can
hold down the keyboard shortcut for the
Move (w), Rotate (e), or Scale (r) tool
and click to bring up that tool’s marking
menu (Figure 4.11). Maya’s Transform
marking menus include shortcuts to
many of the tools’ options.
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Figure 4.10 By holding down s and dragging with
the middle mouse button, you can move an object
without using the manipulator handles.

Figure 4.11 The Scale tool’s marking menu includes
shortcuts for scaling proportionally and changing the
pivot options for components.



To scale an object or component using
the Scale tool:

1. Select an object or component by
clicking it.

2. Press r , or click the Scale tool icon 
in the toolbar.

The Scale manipulator becomes visible
on the object or component (Figure 4.12).

3. Click the small square of the axis on
which you want to scale the object or
component, and drag in the direction you
want the object to scale (Figure 4.13).

or

While pressing s , click and drag with
the middle mouse button anywhere in
the pane in the direction in which you
want the object to scale (Figure 4.14).

This action selects the appropriate
manipulator axis and scales the object 
in that direction.
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Figure 4.12 You use the Scale tool’s manipulator to
scale an object proportionally or along a single axis.

Figure 4.13 Click and drag a Scale tool’s axis to scale
an object along a particular axis.

Figure 4.14 This cylinder is being scaled along the 
x axis by shift-clicking and dragging with the middle
mouse button.



To rotate an object or component
using the Rotate tool:

1. Select an object or component by
clicking it.

2. Press e , or click the Rotate tool icon 
in the toolbar.

The Rotate manipulator becomes visible
on the object or component (Figure 4.15).

3. Click the circle of the axis around which
you want to rotate the object or compo-
nent, and drag in the direction you want
the object to rotate (Figure 4.16).

✔ Tips

■ You can click anywhere within the
Rotate manipulator sphere, and click and
drag to rotate the object without being
constrained to any axis.

■ Once the axis you want to use is yellow
on the manipulator, you can click and
drag anywhere in the pane with the mid-
dle mouse button to rotate the object
around that axis without touching the
axis or the object.

■ The light blue outer ring rotates the object
or component around an axis that always
faces the camera view (Figure 4.17).
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Figure 4.15 The Rotate manipulator is used to rotate
the surface on one or more axes.

Figure 4.16 Click and drag the axis circle to which you
want the object constrained. A gray pie slice shows
you how many degrees you have rotated the object.

Figure 4.17 The light-blue outer ring rotates
the object or component in the view plane.



To translate, rotate, or scale an object
or component using the Channel Box:

1. Click an object or component to select it.

2. In the Channel Box, click once in the
field next to the attribute you want to
change (Figure 4.18).

3. Type a new value in the selected field.

The object reflects the value change
(Figure 4.19).

or

Click to select the attribute’s name, and
then move the mouse over a view pane.
Hold down the middle mouse button,
and drag left or right to interactively
change the value of the selected attribute
(Figure 4.20).

Using the Universal Manipulator
The Universal Manipulator provides easy
access to three transformations in one tool
(Figure 4.21). You can use it to enter exact
values without using the Channel Box, 
and it enables you to quickly perform these
operations around different temporary
center points.
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Figure 4.18 Click the field name of the attribute you
want to change (in this case, Translate X).

Figure 4.19 Changing the Translate X value to 3
moves the cone three units in the positive x direction.

Figure 4.20 You can use the middle mouse button to
interactively change values anywhere in a pane.

Figure 4.21 The Universal Manipulator combines
many functions for quick manipulation. It’s a great
time saver for performing common transformations.

Scale manipulator Rotate manipulator

Size numbers Translation manipulator



The Universal Manipulator also provides
real-time information about how far you
have translated or rotated an object 
(Figure 4.22).

The Universal Manipulator does have its
limits. For instance, it can’t rotate freely in
all directions, and you can’t use it to manip-
ulate components—only objects. 

To translate an object using the
Universal Manipulator:

1. Select an object or component by
clicking it.

2. Press c+t , or click the Universal
Manipulator tool icon .
The Universal Manipulator becomes
visible on the object or component
(Figure 4.23).

3. Click the axis you want to translate, 
and drag the mouse to translate in 
that direction.

or

Click the center circle, and drag the
mouse to translate the object freely.

or

Click once on the tip of the translation
axis, and enter a numerical value in the
box that appears (Figure 4.24).
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Figure 4.22 Using the translation axis displays a
color-coded triangle showing exactly how far you
have moved your object along each axis.

Figure 4.24 Entering a precise value saves
a trip to the Channel Box.

Figure 4.23 The Universal Manipulator shows a
bounding box around your object.

Center circle

Channel
Box



To rotate an object using the 
Universal Manipulator:

1. Select an object or component by
clicking it.

2. Press c+t , or click the Universal
Manipulator tool icon .

3. Click the arrow corresponding to the axis
you want to rotate, and drag the mouse
to rotate on that axis (Figure 4.25).

or

Click once on a rotation arrow, and enter
a numerical value in the box that appears.

To scale an object using the 
Universal Manipulator:

1. Select an object or component by
clicking it.

2. Press c+t , or click the Universal
Manipulator tool icon .

3. Click a vertex of the bounding box, and
drag to scale the object evenly on all axes
(Figure 4.26).

Note that the Universal Manipulator uses
the opposite corner from the one you’ve
selected as the center point for the scale.
This means it scales toward the opposite
corner instead of the center of the object.

or

Click one of the size numbers, and enter
a numerical value.
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Figure 4.25 When you’re rotating an object on an axis
using the Universal Manipulator, the length (in degrees)
of the rotation is displayed near the rotation handle.

Figure 4.26 Scaling with the bounding box scales to
the opposite corner of the one you’ve selected.

Bounding box vertices



✔ Tips

■ To restrict scaling to one axis, hold c
and move the mouse in the direction of
that axis (Figure 4.27), or click a size
number and enter a value. 

■ Pressing s when performing scale
operations performs them from the
center of the object rather than from 
a corner or side. 

■ Pressing c when rotating the object
using the Universal Manipulator rotates
the object around the bounding box
edges. The Universal Manipulator uses
the edge opposite the rotation arrow 
you chose (Figure 4.28).

Using the Show Manipulator tool
The Show Manipulator tool lets you
access the Inputs node of an object (known
as its construction history) to alter a sur-
face or curve. In other words, the Show
Manipulator tool gives you access to certain
attributes used in the creation or manipula-
tion of an object that are usually available
only in the Channel Box or Attribute Editor
(Figure 4.29).

The Show Manipulator tool is commonly
used to adjust spotlights and cameras. When
you use it on a spotlight, the light has three
manipulators instead of one—one to move
the light; one for the light to point at, which
makes adjusting lighting easier; and one rep-
resented by a circle with a tick mark, which
adjusts the attributes to be manipulated. 
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Figure 4.27 Using c lets you scale on an axis
instead of to a corner.

Figure 4.28 Rotating an object around a corner saves
you from having to reposition the pivot point every time.

Figure 4.29 The additional manipulator on the Show
Manipulator tool controls additional input attributes,
saving you from going to the Channel Box. In this
example, End Sweep was changed to less than 
360 degrees by moving the circular manipulator.



To aim a spotlight using the Show
Manipulator tool:

1. Select Create > Lights > Spotlight.

2. Click the Show Manipulator icon in
the toolbar.

The spotlight now has one manipulator
at its base and another in front of the
light (Figure 4.30).

3. Select and move the manipulator at the
base of the spotlight (Figure 4.31).

The spotlight moves with the manipula-
tor but continues to point at the second
manipulator.

4. Select and move the manipulator in front
of the spotlight.

The spotlight remains in place but con-
tinues to point at the manipulator
(Figure 4.32).
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Figure 4.30 Two manipulators appear, giving you more
precise control over what objects the spotlight is pin-
pointing and the direction in which the light is aimed.

Figure 4.32
Move one manipu-
lator to exercise
control over the
light or its target.

Move light
with this
manipulator

Change light direction with this manipulator

Figure 4.31
Select the
manipulator
attached to
the spotlight
to translate
the light.



5. Click twice on the ring that hovers near
the spotlight. 

The manipulators change into a ring
around the cone of light. Each time you
click the ring, you cycle through some of
the cone’s input nodes (Figure 4.33).

6. Click and drag the cube atop the circle
that surrounds the cone.

The cone angle changes interactively as
you drag the mouse (Figure 4.34).

71

Transforming Objects and Components

M
o

vin
g

, R
otatin

g
, an

d S
calin

g
 O

bjects

Figure 4.34 The cone angle controls the width of the
light beam.

Adjusts
cone
angle

Changes which
history node is
currently viewed

Figure 4.33 Most objects display a blue ring from
which you can access that object’s input nodes or
attributes interactively.



About Pivot Points
Each object in Maya has a pivot point. When
you rotate an object, it rotates around its
pivot point, and when you scale an object, 
it scales to and from the pivot point. By
default, the object’s pivot point is at the cen-
ter of the object, but Maya lets you move the
pivot point according to your needs. For
example, if you model a clock, you can posi-
tion the pivot point of each hand at the cen-
ter of the clock rather than the middle of the
hand. This lets you easily rotate the hands
around the face of the clock (Figure 4.35).

To change an object’s pivot 
point position:

1. Select the object whose pivot point you
would like to move.

2. Select the Move tool from the Tool Box,
or press w .

3. Press I/h to go into pivot 
point mode.

The pivot point manipulator is now
visible (Figure 4.36).

4. Click and drag one of the pivot point
manipulator handles to move the pivot
point to a new position (Figure 4.37).

The new position will be the new rota-
tion point for the object.

5. Press I/h to disable pivot 
point mode.

To position the pivot point in the
center of an object:

1. Select the object whose pivot point you
would like to center.

2. Choose Modify > Center Pivot.
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Figure 4.35 This simple clock has had the pivot points
of its hands repositioned to the center of the clock face.

Figure 4.36 By default, an object’s pivot point is
located at the center of the object.

Figure 4.37 You can reposition an object’s pivot point
by using the pivot point manipulator.



Duplication Options
Maya provides duplication shortcuts for
modeling objects with repetitive geometry—
for example, a staircase or flower petals. To
model a flower in a minimum number of
steps, you can make one petal and then
reproduce it many times around the center
(Figure 4.38).

There are three duplication options. The
Duplicate tool creates a new copy of your
object at the same location. The Duplicate
Special tool can be used for more complex
duplications, including ones that apply
changes to the rotation, translation, and
scale of an object. You can also use the
Duplicate Special tool to mirror and create
instances of objects. Duplicate Special is the
only way to duplicate an object’s input graph
or input connection, which will preserve its
construction history (Figure 4.39). (See
Chapter 1 for more information about con-
struction history.) 

Duplicate with Transform duplicates an
object with offsets determined by relative
positioning. It’s a more visual alternative to
Duplicate Special, but without some of the
advanced options.

To duplicate an object:

1. Select an object.

2. Choose Edit > Duplicate (Figure 4.40).

or

Press c+d . Note the lowercase d.

3. Move your new object away from the
original so you can distinguish the two.
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Figure 4.38
This flower was
made with two
objects and one
duplication,
which placed
the petals
around the
center.

Figure 4.39
The sphere’s Inputs
node holds its editable
history attributes.

Figure 4.40 All the duplicate tools can be
found together in the Edit menu.



To duplicate an object with simple
translation:

1. Create a primitive sphere.

2. Choose Edit > Duplicate with Transform
(Figure 4.41).

3. Move the duplicated sphere a few units
in the z direction (Figure 4.42).

4. Choose Edit > Duplicate with Transform.

A new sphere is created. It’s the same
distance from the second sphere that 
the second sphere is from the original
(Figure 4.43).

5. Press s+d .

Another duplicate is made, an equal
distance from the last (Figure 4.44).

✔ Tip

■ You can also use Duplicate with
Transform to apply changes to rotation,
scale, or all three transforms at once.
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Figure 4.42 Move the sphere the distance you would
like your future duplications to copy.

Figure 4.44 Each new copy moves down the axis the
same amount as the original copy.

Figure 4.41
Choose Edit >
Duplicate with
Transform.

Figure 4.43 Duplicate the object again.



Constructing with duplication
Now that you have a general idea of how to
duplicate an object, let’s examine the third
option: Duplicate Special. Duplicate Special
duplicates an object with transformations,
like Duplicate with Transform; but you can
specify the number of duplications and the
precise nature of the transforms, which
makes this option useful for constructing
more elaborate forms.

The key to successfully creating an object
with Duplicate Special lies in placing the
pivot point in the correct position. This
provides the proper axis for the objects to
rotate around (Figure 4.45).

To create a simple staircase:

1. Select the box next to Create > Poly
Primitive > Cube.

The Polygon Cube Tool Settings appear.

2. Change the Single-click Settings to use a
Width of 6.0, and a Height and Depth of
1.0 (Figure 4.46).

3. Click once in the center of the grid. 

A cube with the specified dimensions
appears (Figure 4.47).

4. Press w , or click the Move tool icon 
in the toolbar.

5. Move the cube up so its base rests on 
the grid.

6. Press I/h on the keyboard to go
into pivot point mode.

7. Move the pivot point to the far-left edge
of the cube, using the x-axis manipulator
(Figure 4.48).

8. Press I/h again to turn off pivot
point mode.

continues on next page
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Figure 4.45 The pivot point’s placement determines
the placement of a duplicated surface.

Figure 4.46 Change the Polygon Cube Tool Settings to
create a cube of a specific size.

Figure 4.47 The cube is created when you click once
in the view.

Figure 4.48 The pivot point determines the point in
space around which the staircase rotates.



9. From the Edit menu, select the box
next to Duplicate Special to open the
Duplicate Special options window.

10. Set the duplicate options as follows
(Figure 4.49):

Translate: 0, 1, 0—This setting moves
each new duplicate up the y axis one
unit. The cube is one unit high, so each
copy sits on top of the previous one.

Rotate: 0, 15, 0—This setting rotates
each duplicate 15 degrees more than
the previous one around the y axis.

Scale: .95, .95, .95—This setting scales
each duplicate proportionately to 95
percent the size of the last. The stair-
case gets smaller as it goes higher.

11. Enter 20 in the Number of Copies field.

This setting will create 20 new steps.

12. Click Duplicate.

The specified number of copies are
made and placed above each other after
being rotated and scaled (Figure 4.50).

✔ Tips

■ It’s a good idea to check your options
before duplicating. The previous settings
are retained unless you reset them. To
return the options to their default set-
tings, with the Duplicate Special Options
window open, select Edit > Reset Settings.

■ Move the pivot point farther down the 
x axis before duplicating to make room
for a pole in the center of the staircase
(Figure 4.51).
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Figure 4.50 You can use the Duplicate Special tool to
quickly construct geometric or repetitive shapes like
this staircase.

Figure 4.49 Set the duplicate options as shown to
properly duplicate the cube.

Figure 4.51
The pivot
points of the
steps are
shown here,
revealing that
they form a
straight line up
the center of
the staircase.



Mirroring and 
Instancing Objects
In addition to translating objects, you can
use the Duplicate Special options to create a
mirror image of an object (that is, a reversed
copy of the original). Body parts or charac-
ters make good candidates for mirroring
because many characters are nearly sym-
metrical. This allows you to model one half
of a character and mirror it, saving yourself
almost half the work (Figure 4.52).

Additionally, you can create instances of
objects—duplicates that retain a connection
to the shape of the original (Figure 4.53).
The beauty of this technique is that you can
then edit any of the objects and have each of
the rest follow those edits interactively. For
example, if you’re creating a building with
multiple identical pillars, you can create one
pillar and then create a number of instances
of it to get the additional pillars. If you later
decide to change the look of the pillars, all
you have to do is edit one, and the rest are
updated automatically.

Mirroring
Mirroring an object produces a precise
reverse copy of the object. This technique is
great for symmetrical objects, such as creat-
ing one side of a face and then mirroring the
face across an axis to complete it (Figure
4.54). The pivot point is used as the mirror
axis, which means that the farther the pivot
point is from the object, the farther the mir-
rored copy will be from the original. 

continues on next page
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Figure 4.52 By mirroring a character or anything
symmetrical, you can save a lot of work.

Figure 4.53 Instances of objects mimic the edits of
the first object interactively. Here one poly sphere
reflects the change to the other.

Figure 4.54 You can create half a face and then mirror
it to complete the rest of the face.



You can also use mirroring to place objects
an equal distance away from an axis line,
creating a mirrored copy that’s perfectly
placed (Figure 4.55).

In the following task, you’ll mirror a sphere
across an axis, as if to create two eyes.

To mirror an object:

1. Create a NURBS primitive sphere, or
select another object to mirror.

2. Type -2 in the Translate X field in the
Channel Box (Figure 4.56).

This setting moves the object two units
down the negative x axis.

3. Press w or click the Move tool icon in
the toolbar.

4. Press I/h on the keyboard to go
into pivot point mode.

5. Holding down x , move the pivot point
to the origin (Figure 4.57).

x snaps to the grid, which ensures that
the pivot point is precisely at the origin.

6. Press I/h to get out of pivot-
point edit mode.

7. From the Edit menu, select the box
beside Duplicate Special.

The Duplicate Special Options 
window opens.
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Figure 4.55 Any symmetrical object is ideal for
mirroring. Here, a pair of tires is flipped to the other
side of the x axis.

Figure 4.57 Move the pivot point to the origin to send
the copy an equal distance away from the origin.

Figure 4.56
Type -2 in the Translate
X field of the Channel
Box to move the object
two units in the
negative x direction.



8. Select Edit > Reset Settings in the
Duplicate Special Options window 
to reset the settings, and then set 
the Scale X field to –1.

9. Click Duplicate Special.

A mirrored copy is duplicated an 
equal distance from the pivot point
(Figure 4.58).

✔ Tip

■ Often, mirroring is used in conjunction
with instancing so your modifications
are automatically reflected across the
object (Figure 4.59).

Instancing
Instancing is a great way to save time, both
in modeling and in rendering. An instanced
object follows the edits of the original, mak-
ing instancing ideal for any object that will
have identical copies anywhere else in the
scene (Figure 4.60). Instanced objects are
loaded into memory only once, saving ren-
der time. Very large scenes can be populated
by instanced objects and stay workable. You
can still scale, rotate, and move the objects
independently once they’ve been instanced.

To make an instance of an object:

1. Select an object by clicking it.

2. From the Edit menu, select the box next
to Duplicate Special.

The Duplicate Special Options window
opens.

continues on next page
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Figure 4.58 A mirrored copy is duplicated an equal
distance from the pivot point.

Figure 4.59 Combining mirroring and instancing
allows adjustments to one side of this face to be
reflected on the other.

Figure 4.60 Oil drums are instanced to cut down on
the number of edits that need to be made. The objects
are rotated to hide their similar attributes.



3. Set the Translate X field to 2 and the rest
of the Translate and Rotate fields to 0
(Figure 4.61).

You add a translate here so the copy
doesn’t sit directly on top of the original.

4. For Geometry Type, select Instance
(Figure 4.62).

5. Click Duplicate Special.

The duplicate is now an instance, or
virtual copy, of the original.

6. With one of the objects selected, press
8 to go into component-selection
mode.

7. Marquee-select across the top third of
the object to select one of its compo-
nents (Figure 4.63).

8. Press w, and translate the components
in any direction.

Note that the other object follows the
translation of the selected surface
(Figure 4.64).

✔ Tip

■ Once you’ve created an instance of an
object, you can’t modify its components
independently. However, you can trans-
late, rotate, or scale the whole object
without affecting the other instances. 
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Figure 4.61 Set the Translate X field to 2.

Figure 4.62 Selecting Copy duplicates the object;
however, selecting Instance results in an additional
connection to the original object.

Figure 4.64 The other object follows the translation of
the selected surface but in the opposite direction, like
an object in a mirror.

Figure 4.63
Marquee-select
across the top
third of the object
to select control
vertexes to
manipulate.



Duplicating input connections
Often, you’ll want the construction history
to remain attached to an object when you
create a copy of it. This produces an effect
like instancing but allows you to alter the
objects independently as well. You can do
this by selecting the “Duplicate input con-
nections” check box in the Duplicate Special
Options window. The objects then share the
same Inputs node, and both the original and
the duplicates are changed by it.

To duplicate an object with its input
connections:

1. Select an object that has input connec-
tions attached to it—a primitive sphere,
for example (Figure 4.65).

2. From the Edit menu, select the box next
to Duplicate Special.

The Duplicate Special Options window
opens.

3. Select the “Duplicate input connections”
check box (Figure 4.66).

This option connects the duplicated
object to the Inputs node of the original.
Now, if you alter the Inputs node of one
object, the duplicates are also affected.

4. Type the number of duplicates you want
to produce in the “Number of copies” field.

continues on next page
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Figure 4.66 Select the “Duplicate input connections”
check box in the Duplicate Special Options window to
copy the input connections to the new object.

Figure 4.65 A primitive
sphere’s Inputs node
holds the editable
history of the sphere.



5. Click Duplicate Special.

A copy of the object is made, and its
connections are attached to it (Figure
4.67). The new object sits directly on 
top of the original. 

6. Select the Move tool, and move the
duplicated object away from the original.

7. In the Channel Box, select the End Sweep
attribute name, and drag the middle
mouse button in the View pane to con-
firm the connections.

The End Sweep is changed on both
objects interactively (Figure 4.68).

8. Right-click a sphere, select CVs from the
marking menu, and move a few around. 

When you duplicate with input con-
nections, you can make changes to the
new copies without affecting the rest
(Figure 4.69).
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Figure 4.67 The same makeNurbSphere node is
connected to both spheres.

Figure 4.68 Because both spheres share the input
node makeNurbSphere1, adjusting the sweep of that
node adjusts both spheres.

Figure 4.69 When you retain the Inputs node on dupli-
cated objects, you can continue to make individual
changes to the surfaces.



Soft-Modifying Objects
The Soft Modification tool gives you the
ability to sculpt, or smoothly modify, dense
surfaces (Figure 4.70).

You can use this tool for animation as well
as modeling, because its parameters can be
keyframed as long as the construction histo-
ry has been enabled (see Chapter 1 for more
about construction history). The Soft
Modification tool’s uses range from adjust-
ing a dense facial mesh, to creating smooth
terrain, to animating bulging muscles on a
superhero’s arm (Figure 4.71).

The Soft Modification tool works by tapering
the effect of adjusting points on surfaces. In
Maya 8, this tapering is displayed as a color-
coded gradient while the softMod is selected.
SoftMods allow smooth adjustments of a sur-
face across several points. This technique is
especially useful when you’re working with
dense surfaces: Without the Soft Modification
tool, it would be far too time-consuming to
individually move the large number of compo-
nents required to make smooth changes.

As with the other translation tools, you can
activate the Soft Modification tool and then
select the area of the object you want to
soft-modify. Or, if you select an object first
and then choose the Soft Modification tool,
the effect is automatically applied to the
center of the object. The effect can be
moved at any time, unless you delete the
construction history.
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Figure 4.70 Choose the Soft Modification tool
from the toolbar.

Soft Modification tool

Figure 4.71 Faces, smooth
terrain, and muscles are
just a few examples of what
Soft Modification can do.



To soft-modify an object:

1. Create a primitive polygonal plane
(Create > Poly Primitives > Plane), give 
it Subdivisions Height and Width of 100,
and scale it to about 20 times its original
size (Figure 4.72).

2. Make sure your plane isn’t selected, and
then click the Soft Modification tool
in the toolbar.

3. Click the part of the object where you
want to create the soft modification
(softMod).

A softMod node is added to the surface,
and its manipulator becomes active
(Figure 4.73).

4. Select the y translate axis of the manipu-
lator, and drag it up (Figure 4.74).
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Figure 4.73 Add a softMod to a surface. The orange
and black gradient displays the variable effect of the
softMod.

Figure 4.74 Drag the y axis of the softMod manipulator.

Figure 4.72 In the Channel Box, increase the
Subdivisions Width and Height to create a dense
polygon plane.



5. Click the Cycling Index to display the
Falloff manipulator (Figure 4.75).

6. Click and drag the red circle surrounding
the Falloff manipulator to increase or
decrease the drop-off area (Figure 4.76).

7. Click the translation icon on the Falloff
manipulator, and drag it from side to side
(Figure 4.77).

continues on next page
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Figure 4.76 Click and drag the red circle around the
Falloff manipulator to adjust the drop-off area.

Figure 4.77 Using the Move tool, click and drag the
Falloff manipulator.

Figure 4.75 The Cycling Index is a circle with a line
through it under the softMod manipulator. Click the
Cycling Index to toggle on the Falloff manipulator.

Cycling Index



8. Press c+a to open the Attribute
Editor for the softMod, and select 
the arrow next to the Falloff Curve
(Figure 4.78).

The graph opens in a new window, so
that you can adjust it more easily
(Figure 4.79).

9. Click the ramp to create a new edit
point (Figure 4.80).

10. Click and drag the edit point into the
desired position.

or

Click the box with an x in it to delete
the edit point.

11. Add two edit points, and position them
as shown in Figure 4.81.

You can see the results of editing the
Falloff Curve on the surface of the
softMod you created.

✔ Tips

■ Before clicking the Soft Modification tool
in the toolbar, be sure you don’t have any
objects selected. If you do, a softMod
node will be added to them.

■ If you deselect the Falloff manipulator,
you can click the S icon floating above
the surface and then press t (Show
Manipulator) to reactivate it.

■ Soft modification can work on selected
components as well as the entire object.
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Figure 4.80 …to create edit points.

Figure 4.81 The softMod now has a smooth, wavelike
shape.

Figure 4.79 Click the graph in the Fallout Curve window…

Figure 4.78 The new ability to bring up a larger graph
window makes editing the Falloff Curve much easier.




